Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 165655 - scim should notice IMEngines being installed/updated/removed
Summary: scim should notice IMEngines being installed/updated/removed
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: scim
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
: 186843 (view as bug list)
Depends On: 179807
Blocks: FC5Target SCIM
TreeView+ depends on / blocked
 
Reported: 2005-08-11 06:02 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-28 03:05:08 UTC


Attachments (Terms of Use)
patch for reload engines (deleted)
2005-12-20 05:48 UTC, Qian Shen
no flags Details | Diff

Description Leon Ho 2005-08-11 06:02:16 UTC
Description of problem:
When a new engine installed and if the SCIM is already running, the engine list
will not show the newly installed engines. Currently it requires user to kill
SCIM manually or restart X

Version-Release number of selected component (if applicable):
1.4.0

How reproducible:
everytime

Steps to Reproduce:
1. rpm -e scim-chewing
2. run SCIM
3. rpm -Uvh scim-chewing*
4. Look at the engine list
  
Actual results:
Chewing is not in the list

Expected results:
Chewing should be in the list

Additional info:

Comment 1 Jens Petersen 2005-09-02 04:51:45 UTC
In scim-1.4.2-2 I'm adding a "scim-restart" script which restarts
the main scim-launcher process.  So if one runs it before step 4 and
starts a new application the IME menu should be up to date in the new
application.

Comment 2 Warren Togami 2005-09-08 11:39:53 UTC
Ideally scim could respond to a certain signal and restart itself.  Then scim
packages in %post could killall -SOMESIGNALNAME and all running scim's on that
box would react.  It would need to be a little smart, maybe not restarting scim
immediately as it may be in use.  We can find the 'safe' event oppportunities
like maybe the language bar is dismissed, the user chooses "Reload", and
possibly other chances.

Or maybe this signal idea is just plain crack.  We need more opinions.

Comment 3 Qian Shen 2005-12-20 05:48:18 UTC
Created attachment 122439 [details]
patch for reload engines

I wrote a patch to let CommBackEnd class use newly written reload method to
rescan all the engines, and reload engines again. User can activate it through
"Reload Configuration" button in panel. 
I have send this patch to the upsteam. James Su said he had a better way to
handle this issue. But I have not got any reply from hi by now.

Comment 4 Qian Shen 2006-01-04 02:25:27 UTC
I had a talk with James Su. He said it would unload IMEs unclearly if uses this
reload patch, and would cause some other bugs. He said he has no good solution
for this bug.


Comment 5 Jens Petersen 2006-02-23 02:26:16 UTC
The above patch was removed in 1.4.4-2 because it induces bug 179807.

Comment 6 Jens Petersen 2006-02-23 02:28:05 UTC
scim-restart works fairly well for me fwiw.

Comment 7 Warren Togami 2006-02-23 06:00:06 UTC
The reload-engines patch needs to be made smarter so it only *signals* the user
daemon, and the user daemon decides when it is safe to restart itself.  A bit
more work yes, but this is the only way.


Comment 8 Jens Petersen 2006-03-28 03:05:08 UTC
Upstream is planning to address this issue for scim 2.0.  Closing for now.

Comment 9 Jens Petersen 2006-03-28 03:22:16 UTC
*** Bug 186843 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.