Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 165186 - FC4 installer has an unexpected exception when installing or upgrading from FC2
Summary: FC4 installer has an unexpected exception when installing or upgrading from FC2
Keywords:
Status: CLOSED DUPLICATE of bug 161877
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-04 23:28 UTC by Andy Gray
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-08 22:01:41 UTC


Attachments (Terms of Use)

Description Andy Gray 2005-08-04 23:28:01 UTC
Description of problem:


Whenever I try to install FC4 I get an Error right after choosing to upgrade. 
In a fresh install it occurs immediately after choosing partitioning method.



This is my system:

800 Mhz Celleron-133Mhz FSB

320 MB RAM

Korean Data Systems Visual Sensations-7e

NVIDIA TNT2 with 32 MB Video RAM on AGP slot

Trio64V2/DX with 4 MB Video RAM on PCI slot

Sound Blaster Live 5.1 sound card

3com EtherLink 10/100 (3C905C)

PCMCIA Adapter PCI card

PCMCIA CompactFlash adapter

hda-8GB internal

   hda1-2MB-Fat-Win2K boot

   hda2-100MB-ext3-/boot

   hda3-7.2GB-ext3-/

   hba4-704MB-swap

hdb-DVD+/-R/+/-RW internal

   cdrom-/mnt/cdrom

hdc-6GB internal

   hdc1-6GB-ext3-/mnt/ext3

hdd-6GB internal

   hdd1-6GB-ext3-/mnt/ext3b

hde-128MB CompactFalash card on PCMCIA adapter

   hde1-128MB-ext3-/mnt/CameraCard

sda-32MB imation USB pen drive

   sda1-32MB-vfat-/mnt/FlashDrive

HP DeskJet 632C on USB




How reproducible: Always



Steps to Reproduce:

1. Boot from FC4 DVD and Start installation

2. Get as far as choosing disk partitioning method or choosing to upgrade





Actual results:

Window appears that says there is an unexpected exception, probably a bug, and
to report it here.  then it says:

Traceback (most recent call last):

 File "/usr/lib/anaconda/gui.py", line 873, in

nextClicked

  self.dispatch.gotoNext()

 File "/usr/lib/anaconda/dispatch.py", line 174, in

gotoNext

  self.moveStep()

 File "/usr/lib/anaconda/dispatch.py", line 242

moveStep

  rc = apply(func, self.bindArgs(args))

 File "/usr/lib/anaconda/partitions.py", line 108, in

setFromDisk

  ptype =

partedUtils.get_partition_file_system_type(part)

 File "/usr/lib/anaconda/partedUtils.py", line 140, in

get_partition_file_system_type

  elif (part.get_flag(parted.PARTITION_BOOT) == 1 and



AttributeError: 'NoneType' object has no attribute name





Expected results:

It should have gone trough the partioning menus and continued installing





Additional info:

Please help me, I cant upgrade to FC4 untill this is resolved-thank you everyone
for all your help, and even more, thank you to everyone who has worked on the
Fedora project ever, for making a wonderful free operating system, and
supporting it as well

Comment 1 Andy Gray 2005-08-05 01:29:02 UTC
also, I was using a DVD-RW+ that passed the media check

Comment 2 Jeremy Katz 2005-08-08 22:01:41 UTC

*** This bug has been marked as a duplicate of 161877 ***


Note You need to log in before you can comment on or make changes to this bug.