Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 165 - broken odc format (?)
Summary: broken odc format (?)
Keywords:
Status: CLOSED DUPLICATE of bug 80
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cpio
Version: 5.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-23 09:58 UTC by Marco Colombo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-23 12:23:18 UTC


Attachments (Terms of Use)

Description Marco Colombo 1998-11-23 09:58:30 UTC
# find /bin | cpio -o -H odc | cpio -itv | head -5
9700 blocks
prwS--S-wt   0 16877    root     909938282 Jan  1  1970
cpio: premature end of file

i get the same error whatever directory i list, and even
if i save the first cpio into a file and re-read it later.

Other formats work:
# find /bin | cpio -o -H crc | cpio -itv | head -5
drwxr-xr-x   2 root     root            0 Nov  1 17:38 /bin
-rwxr-xr-x   1 root     root         9764 Apr 24  1998
/bin/chgrp
-rwxr-xr-x   1 root     root        10276 Apr 24  1998
/bin/chmod
-rwxr-xr-x   1 root     root         9592 Apr 24  1998
/bin/chown
-rwxr-xr-x   1 root     root        23156 Apr 24  1998
/bin/cp
9236 blocks
9236 blocks

BTW, on a Solaris 2.5.1 Sparc system, both commands work
perfectly. Archives created on Solaris systems (in odc
format) can be read by Linux (GNU) cpio, while archives
created on Linux cannot be read by either systems. I've
tested this on different RHL5.1 boxes (from 80386 to AMDK5).

--
.TM.

Comment 1 Preston Brown 1998-11-23 12:20:59 UTC
*** This bug has been marked as a duplicate of 80 ***

Comment 2 Preston Brown 1998-11-23 12:21:59 UTC
*** This bug has been marked as a duplicate of 78 ***

Comment 3 Preston Brown 1998-11-23 12:23:59 UTC
*** This bug has been marked as a duplicate of 80 ***


Note You need to log in before you can comment on or make changes to this bug.