Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164911 - support of cyrillic in gtk+ 1.2.x is broken in xorg-x11-6.8.2
Summary: support of cyrillic in gtk+ 1.2.x is broken in xorg-x11-6.8.2
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Russian
TreeView+ depends on / blocked
 
Reported: 2005-08-02 15:55 UTC by Leonid Kanter
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 01:56:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
file open form in xorg-x11-6.8.1 (deleted)
2005-08-02 15:55 UTC, Leonid Kanter
no flags Details
mesh in xorg-x11-6.8.2 (deleted)
2005-08-02 15:56 UTC, Leonid Kanter
no flags Details

Description Leonid Kanter 2005-08-02 15:55:06 UTC
Description of problem:

gtk+-based applications are unable to display cyrillic in xorg-x11 6.8.2
environment. With 6.8.1 everything was OK.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.2-1.EL.13.6

How reproducible:

always

Steps to Reproduce:
1. set locale to ru_RU.UTF-8
2. install any gtk+ based application (for example, xmms or nero-linux)
3. Try to open file
  
Actual results:

You'll see mesh in place of cyrillic characters

Expected results:

Cyrillic characters must be there

Additional info:

100% reproduceable. Downgrade to original rhel4 xorg-x11 6.8.1 fixes this problem.

Comment 1 Leonid Kanter 2005-08-02 15:55:06 UTC
Created attachment 117364 [details]
file open form in xorg-x11-6.8.1

Comment 2 Leonid Kanter 2005-08-02 15:56:40 UTC
Created attachment 117365 [details]
mesh in xorg-x11-6.8.2

Comment 3 Mike A. Harris 2005-08-30 14:01:48 UTC
For official Red Hat Enterprise Linux support, please log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.

A Red Hat support rep will assist you in determining wether this is a
configuration problem or a real bug, and then gather the necessary
details needed to help diagnose the problem.

Thanks in advance.

Comment 4 Leonid Kanter 2005-09-06 13:16:19 UTC
I think I have enough skills to determine wether this is a configuration problem
or not (see
http://www.redhat.com/training/certification/verify/?rhce_cert_display:certno=804005543116524&rhce_cert_display:verify_cb=Verify)

Actually the problem is in following file:

/usr/X11R6/lib/X11/locale/en_US.UTF-8/XLC_LOCALE

If you take this file from xorg-x11-libs-6.8.1-23.EL.i386.rpm and overwrite new
file with it, everything will be OK.

See also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164911

Comment 5 Leonid Kanter 2005-09-06 13:24:38 UTC
Sorry, it should be
See also https://bugs.freedesktop.org/show_bug.cgi?id=4366

Comment 6 Mike A. Harris 2005-09-28 01:56:43 UTC
Thanks, I've carboned myself on the upstream bug for tracking.  Once
upstream agrees upon a fix for the issue, and it's committed to CVS,
we'll review it again and consider including the official upstream
fix in a future update.




Note You need to log in before you can comment on or make changes to this bug.