Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164817 - mailbox flags not updated when checking mail
Summary: mailbox flags not updated when checking mail
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Depends On:
Blocks: FC6Target 170416 FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2005-08-01 16:25 UTC by Chester Hosey
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-21 16:25:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chester Hosey 2005-08-01 16:25:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Evolution does not notice changes made to a displayed folder until another folder is selected for viewing, and then the original is selected again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open Evolution
2. Open Outlook on another machine
3. Using Outlook, delete a message or mark an unread message as read
  

Actual Results:  Even after checking for new messages, Evolution shows the deleted message in the index or continues to show the read messages as unread. Display can usually be refreshed by switching back and forth from another folder (Inbox->Deleted Items->Inbox).

Expected Results:  Attributes and messages should be updated while checking for new messages.

Additional info:

I have not tried this between two copies of Evolution running against Exchange or using Evolution + Outlook Web Access, only a copy of Evolution with a copy of Outlook.

Comment 2 Dave Malcolm 2005-08-18 22:29:20 UTC
Thanks for filing this report.

I've looked through the code; Evolution appears to correctly handle
notifications about new/removed messages and status changes in the messages it
receives from the evolution-exchange-storage backend, but does no global
monitoring for change information of this kind.  Your suggestion would involve a
full rescan on Send/Receive, which could work, but I'm uneasy about the
performance implications.

I'm marking this bug as ASSIGNED since it's correctly assigned to me.  However,
it currently has a very low position in my priority queue, and is not likely to
get fixed in forthcoming updates (although I plan to ensure that the problem is
addressed in RHEL 5).

If this issue is important to you, please contact Red Hat Support to get it
reprioritized.  Thanks.

Comment 3 Chester Hosey 2005-08-19 13:04:47 UTC
This is by far the most courteous and professional response I've received from 
any Red Hat employee.

It's not a high priority for me, I just wanted to make the issue known to Red 
Hat. I like bug reports because I imagine that they give the developer the 
opportunity to prioritize, rather than choosing to filter low-priority tasks.

I appreciate your response. I'm tempted to forward it to the support guys as an 
example of everything a reply to a customer should include.

Comment 10 Matthias Clasen 2006-07-06 21:47:37 UTC
Add to FC6Destop tracker

Comment 11 RHEL Product and Program Management 2006-07-21 16:25:09 UTC
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.