Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164808 - can't compile (link) ethereal 0.10.11 with gcc-3.4: undefined reference to `.LC770'
Summary: can't compile (link) ethereal 0.10.11 with gcc-3.4: undefined reference to `....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc
Version: 4.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://bugs.ethereal.com/bugzilla/sho...
Whiteboard:
Depends On: 157308
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-08-01 16:06 UTC by Elena Zannoni
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-677
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 11:18:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:677 qe-ready SHIPPED_LIVE gcc bug fix update 2005-10-05 04:00:00 UTC

Description Elena Zannoni 2005-08-01 16:06:50 UTC
+++ This bug was initially created as a clone of Bug #157308 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
I (and several others) are not able to compile (actually link) the current
version of Ethereal (0.10.11) using an up-to-date FC3 system.  This was filed as
Ethereal bug #156:

http://bugs.ethereal.com/bugzilla/show_bug.cgi?id=156

Some analysis by people there has us believing that this is a compiler bug (see
below or the Ethereal bug for more details).

I am putting this as a "High" severity bug since it was originally considered a
"blocker" bug for Ethereal (until it was thought to be a compiler bug with a
workaround).  That and compiler bugs scare me.  Feel free to downgrade if you
feel it appropriate.

Version-Release number of selected component (if applicable):
gcc-3.4.3-22.fc3

How reproducible:
Always

Steps to Reproduce:
1. download the ethereal-0.10.11 source or the FC3 SRPM
2. ./configure --without-ucd-snmp (or ./configure --with-ssl)
3. make
(2 & 3 can be replaced with "rpmbuild -ba")


Actual Results:  Linking failed with this error:

/bin/sh ./libtool --mode=link --tag=CC gcc  -DINET6
-D_U_="__attribute__((unused))" -Wall -W  -g -O2 -I/usr/local/include -DXTHREADS
-D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include     -L/usr/local/lib -L/usr/local/lib -o mergecap 
mergecap.o merge.o wiretap/libwiretap.la -Wl,--export-dynamic -lgmodule-2.0 -ldl
-lglib-2.0   -lz 
epan/.libs/libethereal.so: undefined reference to `.LC771'
epan/.libs/libethereal.so: undefined reference to `.LC770'
epan/.libs/libethereal.so: undefined reference to `.LC772'
collect2: ld returned 1 exit status
make[2]: *** [ethereal] Error 1


Expected Results:  Binary should have been created.

Additional info:

NOTE that if I use "gcc32" (gcc32-3.2.3-6) (by doing "CC=gcc32 ./configure
--without-ucd-snmp") instead of "gcc" Ethereal compiles/links just fine (thus
supporting the hypothesis that this is a 'gcc' problem not an Ethereal problem).

NOTE that someone found another "workaround" for this problem: eliminating
having the same string constant in 2 .o files, see:

http://www.ethereal.com/lists/ethereal-dev/200505/msg00069.html

NOTE that I experienced the same problem attempting to build the
ethereal-0.10.11 SRPM released by FC3 (I had been hoping someone had patched
something before generating that SRPM but now I think that maybe the machine
used to build the binary RPM isn't at the latest (released) compiler version?).

Comment 2 Red Hat Bugzilla 2005-10-05 11:18:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-677.html



Note You need to log in before you can comment on or make changes to this bug.