Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164458 - Crash in date selector when selecting end of a recurrence
Summary: Crash in date selector when selecting end of a recurrence
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-07-27 23:39 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-21 17:05:35 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2005-07-27 23:39:39 UTC
Description of problem:
I can enter a start date and time for an event. If I try to set the event to
repeat every 7 days until a set date, a new drop down appears which includes
both a date and a drop down button. Clicking the dropdown kills evolution.
Manually editting the date is ignored.

Version-Release number of selected component (if applicable):
evolution-webcal-2.3.90.1
evoltion-2.3.5-1.1

How reproducible:
Always

Steps to Reproduce:
1. Setup a caledar event.
2. Set the event to repeat every 7 days and attempt to set the end date by
either manually editting the date in the box or by clicking the down button
3.
  
Actual results:
The following throwback is given

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1209039184 (LWP 28579)]
[New Thread -1306526800 (LWP 28607)]
[New Thread -1304786000 (LWP 28590)]
[New Thread -1293972560 (LWP 28588)]
[New Thread -1283482704 (LWP 28587)]
[New Thread -1258103888 (LWP 28586)]
[New Thread -1247614032 (LWP 28583)]
[New Thread -1237124176 (LWP 28582)]
[New Thread -1226634320 (LWP 28581)]
0x00806402 in __kernel_vsyscall ()
#0  0x00806402 in __kernel_vsyscall ()
#1  0x00c5cfcb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x074cf2ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x0805f68a in segv_redirect (sig=11) at main.c:424
#4  <signal handler called>
#5  0x00e51d27 in e_date_edit_show_date_popup (dedit=0xd7eff20)
    at e-dateedit.c:1205
#6  0x004e01a7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#7  0x004d37ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8  0x004e329e in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#9  0x004e4bd8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x004e4f29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#11 0x00ee06d7 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x00ee2438 in gtk_button_get_alignment ()
   from /usr/lib/libgtk-x11-2.0.so.0
#13 0x004e01a7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#14 0x004d31b6 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#15 0x004d37ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#16 0x004e2ef3 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#17 0x004e4bd8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#18 0x004e4f29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#19 0x00ee0654 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x00ee1955 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x00fb9502 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#22 0x004d31b6 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#23 0x004d37ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#24 0x004e342a in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#25 0x004e4935 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#26 0x004e4f29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#27 0x010af5b9 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#28 0x00fb668c in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x00fb6bbd in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#30 0x003bc1b5 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#31 0x07154b7e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0x07157b86 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#33 0x07157e73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#34 0x07236625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#35 0x0805fb06 in main (argc=226443936, argv=0xbfe32ca4) at main.c:602

Thread 9 (Thread -1226634320 (LWP 28581)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833f730) at e-msgport.c:511
	msg = 
Thread 8 (Thread -1237124176 (LWP 28582)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833f730) at e-msgport.c:511
	msg = 
Thread 7 (Thread -1247614032 (LWP 28583)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833cba8) at e-msgport.c:511
	msg = 
Thread 6 (Thread -1258103888 (LWP 28586)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833f730) at e-msgport.c:511
	msg = 
Thread 5 (Thread -1283482704 (LWP 28587)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833f730) at e-msgport.c:511
	msg = 
Thread 4 (Thread -1293972560 (LWP 28588)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008ac117 in e_msgport_wait (mp=0x833f6d8) at e-msgport.c:511
	msg = 
Thread 3 (Thread -1304786000 (LWP 28590)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0654710c in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x071579d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x07157e73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x071f53de in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x071710a4 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00c57b89 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x0655107e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread -1306526800 (LWP 28607)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0654710c in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x071579d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x07157e73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0054441a in startup_mainloop (arg=0x0) at e-book.c:3708
	loop = 
Thread 1 (Thread -1209039184 (LWP 28579)):
#0  0x00806402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c5cfcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x074cf2ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805f68a in segv_redirect (sig=11) at main.c:424
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x00e51d27 in e_date_edit_show_date_popup (dedit=0xd7eff20)
    at e-dateedit.c:1205
	priv = (EDateEditPrivate *) 0xd7f42a0
	calendar = 

Expected results:
The end date is accepted from either the dropdown itself or if editted by hand

Additional info:

Comment 1 Dave Malcolm 2005-07-28 20:42:50 UTC
Thanks for the report; I'm seeing this as well.

Looks like dedit->priv gets NULLed (and freed?) inside call to gtk_grab_add in
e_date_edit_show_date_popup; hence local priv is pointing at garbage, and the
call to gdk_pointer_grab crashes.  Exact pattern varies when run in debugger,
suggesting some kind of memory-handling problem.

Retitling bug to be more descriptive.

Comment 2 Dave Malcolm 2005-07-28 20:44:55 UTC
Changing component from evolution-webcal to evolution

Comment 3 Dave Malcolm 2005-08-18 04:12:56 UTC
Are you still seeing this with the most recent packages in rawhide?

Comment 4 Emmanuel Kowalski 2005-12-13 15:18:02 UTC
This still happens with the current FC4 packages:

evolution-2.2.3-2.fc4.i386.rpm
evolution-data-server-1.2.3-3.fc4.i386.rpm
evolution-webcal-2.2.0-1.i386.rpm

As a workaround, for me at least, entering the date with the keyboard does
work and gives the recurrent event I want.

Also I remember this working with the previous version, but I don't have it
installed anymore to check...

Comment 5 Paul F. Johnson 2005-12-21 17:05:35 UTC
This now appears to be working happily in rawhide. I'll close it.


Note You need to log in before you can comment on or make changes to this bug.