Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164108 - Kernel 2.6.12-1.1372_FC3 does not boot - cannot insert ext3 module
Summary: Kernel 2.6.12-1.1372_FC3 does not boot - cannot insert ext3 module
Keywords:
Status: CLOSED DUPLICATE of bug 163437
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-25 01:51 UTC by Philippe Rigault
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-27 15:06:39 UTC


Attachments (Terms of Use)

Description Philippe Rigault 2005-07-25 01:51:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.1 (like Gecko)

Description of problem:
Kernel 2.6.12-1.1372_FC3smp does not boot on my box (Pogo Vorticon64, see  
details below).  
I have to revert to older kernels (e.g 2.6.11-1.27_FC3smp) to boot correctly.  

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install kernel kernel-smp-2.6.12-1.1372_FC3   
2. Reboot with this kernel  
   

Actual Results:  Boot fails immediately with this output: 
   
Decompressing Linux...done.   
Booting the kernel.   
Red Hat nash version 4.1.18 starting   
insmod: error inserting '/lib/ext3.ko': -1 Unknown symbol in module   
ERROR: /sbin/udevstart exited abnormally!   
mkrootdev: label /1 not found   
umount /sys failed: 16   
mount: error 19 mounting ext3   
mount: error 2 mounting none   
switchroot: mount failed: 22   
umount /initrd/dev failed: 2   
Kernel panic - not syncing: Attempted to kill init!   
  

Expected Results:  Boot completes    
   
Note: when  2.6.11-1.27_FC3smp boots, I get this additional line at the  
beginning: 
  
Decompressing Linux...done.    
Booting the kernel. 
audit(1122239850.305:0): initialized  <---- Additional line   
Red Hat nash version 4.1.18 starting    
... 
  

Additional info:

Hardware: Pogo Vorticon64   
Dual Opteron 246, 4GB RAM   
Tyan S2885 Motherboard   
3ware 9506-4LP controller with 4x250GB SATA disks   
  
Partitions: *NOTE* that the partition mounted as '/' (/dev/sda8) has the 
unusual label '/1' because an older partition has the label '/'. 
This works fine with previous kernels (as expected, because there is nothing 
wrong with this). 
Filesystem    Type  Label Mounted on 
/dev/sda8     ext3  /1    / 
/dev/sda2     ext3  /     /FC1 
/dev/sda11    ext3  /big1 /big1 
/dev/sda12    ext3  /big1 /big2 
/dev/sda1     ext3  /boot /boot 
/dev/sda6     ext3  /home /home 
/dev/sda10    ext3  /opt  /opt 
/dev/sda5     ext3  /tmp  /tmp 
/dev/sda3     ext3  /opt  /usr 
/dev/sda9     ext3  /var  /var 
/dev/sda13    ext3  none  /big3 
/dev/sda14     xfs  none  /big4

Comment 1 Philippe Rigault 2005-07-25 20:41:04 UTC
Sorry, typo above: 
>/dev/sda3     ext3  /opt  /usr  
Should be: 
/dev/sda3     ext3  /usr  /usr 
 
Two more important pieces of information:    
    
1. I have confirmed this bug today on another machine:    
Sun Sunfire V20z    
Dual Opteron 244, 2GB RAM    
LSI Logic (Fusion) U320 SCSI (2x73GB)    
    
Filesystem    Type  Label  Mounted on    
/dev/sda8     ext3  /      /    
/dev/sda1     ext3  /boot  /boot    
/dev/sda7     ext3  /home  /home    
/dev/sda9      xfs  backup /backup    
/dev/sda6     ext3  /tmp  /tmp    
/dev/sda2     ext3  /usr  /usr    
/dev/sda5     ext3  /var  /var    
 
Wih this box, the error message is a little different: 
Here is the end of it: 
... 
mptscsih: Unknown symbol mot_HardResetHandler 
mptscsih: Unknown symbol ioc_list 
insmod: error inserting '/lib/mptscsih.ko': -1 Unknown symbol in module 
ERROR: /sbin/udevstart exited abnormally! 
creating root device 
mkrootdev: label / not found 
umount /sys failed: 16 
mount: error 19 mounting ext3 
mount: error 2 mounting none 
Switching to new root 
switchroot: mount failed: 22 
umount /initrd/dev failed: 2 
Kernel panic - not syncing: Attempted to kill init! 
 
Call Trace:<ffffffff80138164>{panic+196} <ffffffff8034f811>{__down_read+49} 
       <ffffffff80207ef1>{__up_read+33} <ffffffff8013ae53>{do_exit+99} 
       <ffffffff80207db1>{__up_write+49} <ffffffff8013ba8f>{do_group_exit+239} 
       <ffffffff8010eaa6>{system_call+126} 
 
2. This affects *ONLY* the smp kernel: 
- 2.6.12-1.1372_FC3 boots fine 
- 2.6.12-1.1372_FC3smp does not boot 
 

Comment 2 Matthew Kent 2005-07-26 23:01:38 UTC
I can verify this is happening as described although the modules insmod seems to
puke on seem random. Once was ext3 another was sata_sil.

We attempted to upgrade the kernels on 3 FC3 dual opteron servers to
2.6.12-1.1372_FC3smp this afternoon with tragic results. None of the servers
would boot, but an indentical server, save for being single cpu, took the update
and rebooted just fine. 

This is a big issue, would appreciate someone taking a look.

Comment 3 Philippe Rigault 2005-07-26 23:10:29 UTC
> This is a big issue, would appreciate someone taking a look. 
Indeed, I have here twenty Dual-Opteron and a Quad-Opteron that are stuck with 
older smp kernels.  

Comment 4 Matthew Kent 2005-07-27 14:16:21 UTC
Looks like most of these issues have been directed to bug id 163437 , still no
word on a fix though.

Comment 5 Frank Ch. Eigler 2005-07-27 15:06:39 UTC

*** This bug has been marked as a duplicate of 163437 ***


Note You need to log in before you can comment on or make changes to this bug.