Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 164096 - Kickstart install crashed on keyerror: 'openoffice'
Summary: Kickstart install crashed on keyerror: 'openoffice'
Keywords:
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-24 21:22 UTC by Charles Curley
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 14:12:16 UTC


Attachments (Terms of Use)
Dump of python error. (deleted)
2005-07-24 21:27 UTC, Charles Curley
no flags Details
anaconda log of installation (deleted)
2005-07-24 21:30 UTC, Charles Curley
no flags Details
The kickstart file (deleted)
2005-07-24 21:32 UTC, Charles Curley
no flags Details

Description Charles Curley 2005-07-24 21:22:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I made a good manual installation, and then used the anaconda-ks.cfg file as the basis for a kickstart file (attached) served via NFS. The kickstart file excludes a number of OpenOffice.org packages. Package selection fails with the following:


The failure is in line 1559 of kickstart.py, in setGroupSelection.

I have tried twice to install via kickstart, with and without VNC, and both times it failed. The failure point is the same, s I doubt it is lack of memory. The manchine has 240 MB.


Version-Release number of selected component (if applicable):
FC4 Anaconda

How reproducible:
Always

Steps to Reproduce:
1. Boot to installation CD, using options to point to the kickstart file.
2. Wait.
3.
  

Actual Results:  Got the error described above.

Expected Results:  Sucessful package selection & installation.

Additional info:

Comment 1 Charles Curley 2005-07-24 21:27:45 UTC
Created attachment 117109 [details]
Dump of python error.

Comment 2 Charles Curley 2005-07-24 21:30:42 UTC
Created attachment 117111 [details]
anaconda log of installation

Comment 3 Charles Curley 2005-07-24 21:32:32 UTC
Created attachment 117112 [details]
The kickstart file

Comment 4 Charles Curley 2005-07-24 23:01:33 UTC
I was able to get a good installation by commenting out (prepending '# ' to each
line) all of the excluded package names (-foo). I was then able to crash the
installation by commenting back in '-slrn'.

Comment 5 Chris Lumens 2005-07-25 14:12:16 UTC

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.