Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163930 - Crash starting writer
Summary: Crash starting writer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
: 163821 163945 164026 164028 164159 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-22 02:02 UTC by Rodd Clarkson
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 1.9.120-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-23 14:34:18 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2005-07-22 02:02:26 UTC
Description of problem:

Writer crashes on start-up.

It displays a dialog saying that:
"OOo has crashed! Paste this text into you bugreport" (should there be a space
between bug and report?)

Here's the output:

0x20c959: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e959
0x20d15a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f15a
0xdcd420:  + 0x420 (__kernel_sigreturn + 0x0)
0xbfa7468c: ????????
0x3d4ce6: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1ece6
(ucb::Content::insertNewContent(rtl::OUString const&,
com::sun::star::uno::Sequence<rtl::OUString> const&,
com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&, ucb::Content&) +
0x5a)
0x4b894e0: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x454e0
(utl::UCBContentHelper::MakeFolder(ucb::Content&, String const&, ucb::Content&,
unsigned char) + 0x1a0)
0x24df854: /usr/lib/openoffice.org2.0/program/fsstorage.uno.so + 0xa854
0x24da7af: /usr/lib/openoffice.org2.0/program/fsstorage.uno.so + 0x57af
0x2609cb4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xeecb4
0x260b515: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xf0515
0x25ef2f5: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xd42f5
0xb68224: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x25224
0xb6836c: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2536c
0xb6922c: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2622c
0x29684f0: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x74f0
0x2967eb2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x6eb2
0x25ed192: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xd2192
0x25bc5eb: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xa15eb
0x25bcd2d: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xa1d2d
0x25669b5: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4b9b5
0x256ad80: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4fd80
0x1ea4112: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x17a112
0x1eacf16: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x182f16
(SfxTopViewFrame::SfxTopViewFrame(SfxFrame*, SfxObjectShell*, unsigned short) +
0x1d8)
0x1eaf323: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x185323
(SfxTopFrame::InsertDocument(SfxObjectShell*) + 0x43b)
0x1dc6272: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9c272
0x1e92541: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x168541
0x25fbcda: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0cda
0x25fbe9d: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0e9d
0x25fbf56: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0f56
0x254feef: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x34eef
0x80719ed: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x299ed
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0xf27)
0x806b70f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x2370f
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x10b)
0x8060dd3: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18dd3
(desktop::Desktop::OpenDefault() + 0x25f)
0x8061e9c: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x19e9c
(desktop::Desktop::OpenClients() + 0x43c)
0x8065d2d: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1dd2d
(desktop::Desktop::OpenClients_Impl(void*) + 0x25)
0x510b5e2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x825e2
0x5260b63: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d7b63
0xfd5f82: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ef82
0xffb731: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x44731
(SalDisplay::DispatchInternalEvent() + 0xad)
0xcc49e7: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa9e7
0xf51df0: /usr/lib/libglib-2.0.so.0 + 0x26df0
0xf4fb8e: /usr/lib/libglib-2.0.so.0 + 0x24b8e (g_main_context_dispatch + 0x1dc)
0xf52b96: /usr/lib/libglib-2.0.so.0 + 0x27b96
0xf53078: /usr/lib/libglib-2.0.so.0 + 0x28078 (g_main_context_iteration + 0x66)
0xcc460d: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa60d
0xffd471: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46471
(X11SalInstance::Yield(unsigned char) + 0x29)
0x5111988: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88988
(Application::Yield() + 0x50)
0x51119c6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x889c6
(Application::Execute() + 0x26)
0x80656ee: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d6ee
(desktop::Desktop::Main() + 0x149a)
0x5116db5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ddb5 (SVMain()
+ 0x45)
0x806077f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1877f (sal_main +
0x47)
0x6fcf2f: /lib/libc.so.6 + 0x14f2f (__libc_start_main + 0xdf)
0x80606b5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x186b5
(Window::RequestHelp(HelpEvent const&) + 0x31)


Version-Release number of selected component (if applicable):

openoffice.org-core-1.9.119-1.2.0.fc5


How reproducible:

Always.


Steps to Reproduce:
1. Click on the open office writer icon in Applications > Office > Open Office
Writer
  
Actual results:

Crash with reported dialog


Expected results:

Open of word processor for word processing


Additional info:

This also happens for Impress and Calc (would you like the output for these too?)

Comment 1 Caolan McNamara 2005-07-22 09:43:31 UTC
*** Bug 163945 has been marked as a duplicate of this bug. ***

Comment 2 Rodd Clarkson 2005-07-23 12:48:36 UTC
This is fixed in the current release.  Thanks Caillon

It seems I (the reporter) can't mark this bug as fixed, so you'll have to do so
for me.

Comment 3 Caolan McNamara 2005-07-23 14:24:49 UTC
*** Bug 164026 has been marked as a duplicate of this bug. ***

Comment 4 Caolan McNamara 2005-07-23 14:25:43 UTC
*** Bug 164028 has been marked as a duplicate of this bug. ***

Comment 5 Caolan McNamara 2005-07-23 14:30:42 UTC
*** Bug 163821 has been marked as a duplicate of this bug. ***

Comment 6 Caolan McNamara 2005-07-23 14:34:18 UTC
apologies all, I made a test build with all the gcc security flags enabled, 
"- experiment with security flags" and let it into the wild prematurely. i.e.
1.9.119-1 is worthless. If anything persists in 1.9.120-1 let me know as a
seperate bug.

Comment 7 Caolan McNamara 2005-07-25 14:57:00 UTC
*** Bug 164159 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.