Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163877 - pwc (phillips webcam) does not work in 2.6.12-1.1372_FC3
Summary: pwc (phillips webcam) does not work in 2.6.12-1.1372_FC3
Keywords:
Status: CLOSED DUPLICATE of bug 159608
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 19:02 UTC by Derek Atkins
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-22 11:58:34 UTC


Attachments (Terms of Use)

Description Derek Atkins 2005-07-21 19:02:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Netscape/7.1

Description of problem:
I've got a logitech webcam that has been working just fine in the 2.6.11 kernels.  When I use it under 2.6.11 (even as recent as 2.6.11-1.35_FC3) it works just fine:

pwc Philips webcam module version 9.0.2-unofficial loaded.
pwc Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
pwc Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
pwc the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and
VCS-UM100.
pwc Logitech QuickCam Notebook Pro USB webcam detected.
pwc Registered as /dev/video0.
usbcore: registered new driver Philips webcam
usb 3-1: modprobe timed out on ep0out
usb 3-1: modprobe timed out on ep0out
usb 3-1: modprobe timed out on ep0in
usbcore: registered new driver snd-usb-audio
pwc Failed to set LED on/off time.
pwc type = 740
pwc type = 740
pwc set_video_mode(176x144 @ 10, palette 15).
pwc decode_size = 1.
pwc Using alternate setting 1.
pwc set_video_mode(320x240 @ 10, palette 15).
pwc decode_size = 3.
pwc Using alternate setting 3.


However under 2.6.12-1.1372_FC3, it's detected but does not work properly:

Jul 21 13:18:31 cliodev kernel: pwc Philips webcam module version 9.0.2-unofficial loaded.
Jul 21 13:18:31 cliodev kernel: pwc Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
Jul 21 13:18:31 cliodev kernel: pwc Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
Jul 21 13:18:31 cliodev kernel: pwc the Creative WebCam 5 & Pro Ex, SOTEC Afina
Eye and Visionite VCS-UC300 and VCS-UM100.
Jul 21 13:18:31 cliodev kernel: pwc Logitech QuickCam Notebook Pro USB webcam detected.
Jul 21 13:18:31 cliodev kernel: pwc Registered as /dev/video0.
Jul 21 13:18:31 cliodev kernel: usbcore: registered new driver Philips webcam
Jul 21 13:18:33 cliodev kernel: usbcore: registered new driver snd-usb-audio
Jul 21 13:18:59 cliodev kernel: pwc Failed to set LED on/off time.
Jul 21 13:19:15 cliodev kernel: pwc Closing video device: 153 frames received, dumped 0 frames, 2 frames with errors.



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Plug in webcam
2. Run camstream
3. Open the device.  Notice how you have no picture.
  

Actual Results:  No picture data.

Expected Results:  I should have received video data from the webcam.

Additional info:

It's something that changed between kernel-2.6.11-1.35_FC3 and kernel-2.6.12-1.1372_FC3, because it worked in the former and fails in the latter.

Comment 1 Warren Togami 2005-07-22 11:58:34 UTC

*** This bug has been marked as a duplicate of 159608 ***


Note You need to log in before you can comment on or make changes to this bug.