Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163865 - floppy mounting with new kernel 2.6.12
Summary: floppy mounting with new kernel 2.6.12
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 17:47 UTC by Andrew
Modified: 2013-03-06 03:43 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-12 01:24:11 UTC


Attachments (Terms of Use)
A stab at recognizing the floppy (deleted)
2005-07-28 21:20 UTC, Jason Tibbitts
no flags Details | Diff
Another attempt (deleted)
2005-07-28 21:53 UTC, Jason Tibbitts
no flags Details | Diff
Another attempt (deleted)
2005-07-28 21:53 UTC, Jason Tibbitts
no flags Details | Diff

Description Andrew 2005-07-21 17:47:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0.5

Description of problem:
After updating to kernel-2.6.12-1.1372_FC3 (and rebooting to active it), Gnome does not show the floppy icon in the Computer folder.  There is no apparent way for non-technical desktop users to mount the floppy.





Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. kernel-2.6.12-1.1372_FC3
2. In Gnome, open Computer

  

Actual Results:  Floppy icon is missing.

Expected Results:  Floppy icon should be there.

Additional info:

I reverted to kernel-2.6.11-1.27_FC3, and it worked as expected: the Floppy icon was in Computer.  It was easy to mount the floppy.

Earlier, I did not have problem with any of these kernels:

kernel-2.6.9-1.667
kernel-2.6.10-1.770_FC3
kernel-2.6.11-1.14_FC3
kernel-2.6.11-1.27_FC3

Comment 1 Jason Tibbitts 2005-07-28 18:38:07 UTC
Handling of the floppy device seems to have changed significantly with the new
kernel.  I have two machines with identical hardware, one running
2.6.11-1.35_FC3 and the other running 2.6.12-1.1372_FC3.

Under 2.6.11, /sys/bus/platform/devices/floppy0 doesn't contain much:

/sys/bus/platform/devices/floppy0
|-- detach_state
`-- power
    `-- state

Under 2.6.12, the directory is named "floppy.0" (note the added period) and is
organized differently:

/sys/bus/platform/devices/floppy.0
|-- block -> ../../../block/fd0
|-- bus -> ../../../bus/platform
`-- power
    `-- state

Under 2.6.12, lshal shows nothing about the floppy.

Under 2.6.11, lshal shows the following:

udi = '/org/freedesktop/Hal/devices/legacy_floppy_0'
  block.storage_device = '/org/freedesktop/Hal/devices/legacy_floppy_0'  (string)
  storage.policy.mount_option.fscontext=system_u:object_r:removable_t = true  (bool)
  storage.policy.desired_mount_point = 'floppy'  (string)
  storage.policy.mount_filesystem = 'auto'  (string)
  storage.policy.should_mount = true  (bool)
  info.udi = '/org/freedesktop/Hal/devices/legacy_floppy_0'  (string)
  info.category = 'storage'  (string)
  info.capabilities = 'block storage'  (string)
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  storage.model = 'Floppy Drive'  (string)
  storage.vendor = ''  (string)
  storage.physical_device = '/org/freedesktop/Hal/devices/computer'  (string)
  storage.no_partitions_hint = true  (bool)
  storage.automount_enabled_hint = false  (bool)
  storage.media_check_enabled = false  (bool)
  storage.removable = true  (bool)
  storage.hotpluggable = false  (bool)
  storage.drive_type = 'floppy'  (string)
  storage.bus = 'platform'  (string)
  block.have_scanned = false  (bool)
  block.no_partitions = true  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 2  (0x2)  (int)
  block.is_volume = false  (bool)
  block.device = '/dev/fd0'  (string)
  info.vendor = ''  (string)
  info.product = 'Legacy Floppy Drive'  (string)
  storage.legacy_floppy.number = 0  (0x0)  (int)
  platform.linux.sysfs_path = '/sys/devices/platform/floppy0'  (string)
  linux.sysfs_path_device = '/sys/devices/platform/floppy0'  (string)
  linux.sysfs_path = '/sys/devices/platform/floppy0'  (string)
  info.bus = 'platform'  (string)

I think a HAL update is required.

Comment 2 Jason Tibbitts 2005-07-28 21:18:25 UTC
Applying the attached patch sort of helps; lshal will show some info for the floppy:

udi = '/org/freedesktop/Hal/devices/legacy_floppy_144771712'
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  block.storage_device = '/org/freedesktop/Hal/devices/legacy_floppy_144771712'
 (string)
  info.udi = '/org/freedesktop/Hal/devices/legacy_floppy_144771712'  (string)
  info.vendor = ''  (string)
  info.product = 'Legacy Floppy Drive'  (string)
  storage.legacy_floppy.number = 144771712  (0x8a10a80)  (int)
  platform.linux.sysfs_path = '/sys/devices/platform/floppy.0'  (string)
  linux.sysfs_path_device = '/sys/devices/platform/floppy.0'  (string)
  linux.sysfs_path = '/sys/devices/platform/floppy.0'  (string)

but many attributes are missing and no entry is added to /etc/fstab.

Comment 3 Jason Tibbitts 2005-07-28 21:20:02 UTC
Created attachment 117247 [details]
A stab at recognizing the floppy

Comment 4 Jason Tibbitts 2005-07-28 21:53:13 UTC
Created attachment 117248 [details]
Another attempt

This one seems to work.  After rebuilding with this patch, lshal shows the full
complement of floppy info, the directory is created in /media and the fstab
entry is present.

I believe this patch is safe for hosts still running the 2.6.11-1.35_FC3 kernel
as well.

Comment 5 Jason Tibbitts 2005-07-28 21:53:19 UTC
Created attachment 117249 [details]
Another attempt

This one seems to work.  After rebuilding with this patch, lshal shows the full
complement of floppy info, the directory is created in /media and the fstab
entry is present.

I believe this patch is safe for hosts still running the 2.6.11-1.35_FC3 kernel
as well.

Comment 6 Jason Tibbitts 2005-07-30 05:12:06 UTC
Could someone with privileges (or the original reporter) change the component to
"hal"?  Unless a future kernel update is going to change the sysfs name for the
floppy from "floppy.0" back to "floppy0", that is.

Comment 7 Tim Waugh 2005-07-30 22:45:15 UTC
Changing component and reassigning.

Comment 8 Jason Tibbitts 2005-09-15 17:12:47 UTC
FYI, the HAL packages that I use are at http://www.math.uh.edu/~tibbs/rpms/hal/
They have this patch applied but are otherwise unchanged from the Red Hat
packages.  They are unsigned.

Comment 9 Scott Fortney 2005-10-14 18:01:21 UTC
This has been an issue since the change to 2.6.12-1xxx.  When is a fix going to
be applied?  The RPMS at  http://www.math.uh.edu/~tibbs/rpms/hal/ don't have any
instructions for installation and are not "official".  This is unaccepable as
floppy access is still a daily function for me and I suspect others as well.



Comment 10 brucem 2006-01-28 18:10:57 UTC
Folks, My $0.02 worth- I'm not able to try the posted 32 bit rpms. I'd really
appreciate an update for fc3 amd_64. I do use the floppy from time to time. I
further suspect this relates to a similar problem with usb stick functionality.
The usb problem has become an even more significant limitation.

Comment 11 Jason Tibbitts 2006-01-28 19:12:41 UTC
This particular bug has nothing to do with USB sticks.  The only issue is that a
kernel update changed the name of floppy devices in the sysfs tree.  If you're
having a problem with USB sticks, you will need to search for a bug relating to
this problem.  Of course, at this point FC3 is only going to get security
updates from Fedora Legacy, so here is little chance of this or any other
(non-security-related) FC-3 bug being fixed.

Now, none of my x86_64 machines have floppies, but I tried to build some
packages for you.  Unfortuantely the build failed with a link error; it looks
like it's trying to link against the 32-bit version of libpopt.so.

Anyway, I provided an SRPM, so you could always try to build it yourself.

Comment 12 brucem 2006-01-31 05:58:26 UTC
Thanks for the attempt at a build. I may try reverting to an older kernel. If I
find I can't live with that, then your sources and a reading of the rpm how-to
may be the way I go. 

Comment 13 brucem 2006-03-12 19:13:42 UTC
Jason, I'm definitely out of my depth when it comes to correcting this, but it
seems likely I'm getting the same error when I try to rebuild using your srpm.
Here's a snip from the end of my rebuild attempt:

/bin/sh ../libtool --tag=CC --mode=link gcc  -O2 -g -pipe -m64 -Wall
-Wchar-subscripts -Wm issing-declarations -Wnested-externs -Wpointer-arith
-Wcast-align -Wsign-compare   -o libh al.la -rpath /usr/lib64  libhal.lo
-ldbus-1    -lpopt
gcc -shared  .libs/libhal.o  -ldbus-1 /usr/lib/libpopt.so  -m64 -Wl,-soname
-Wl,libhal.so. 0 -o .libs/libhal.so.0.0.0
/usr/lib/libpopt.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [libhal.la] Error 1



Comment 14 Matthew Miller 2006-07-10 22:39:24 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!


Comment 15 petrosyan 2008-02-12 01:24:11 UTC
Fedora Core 3 is not maintained anymore.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.


Note You need to log in before you can comment on or make changes to this bug.