Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163842 - eclipse-changelog fails to open Changelog file.
Summary: eclipse-changelog fails to open Changelog file.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-changelog
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On: 162447
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 15:03 UTC by Jeff Pound
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-09 17:10:10 UTC


Attachments (Terms of Use)
eclipse log file (deleted)
2005-07-21 15:03 UTC, Jeff Pound
no flags Details

Description Jeff Pound 2005-07-21 15:03:55 UTC
Description of problem:
The plug-in cannot open the changelog file.

Version-Release number of selected component (if applicable):
eclipse-3.1.0_fc-2 and eclipse-changelog-2.0.1_fc-22

How reproducible:
Always

Steps to Reproduce:
1. Make a Changelog entry (Ctrl+alt+c)
  
Actual results:
An error dialog is shown with the message '"Insert Changelog entry" did not
complete normally. Reason: org.eclipse.ui.internal.ErrorEditorPart'

An empty editor is then open with the message 'Unable to create this part do to
an internal error. Reason for failure: Cannot create file buffer'

Expected results:
Changelog should open normally

Additional info:
Stack trace attached.

Comment 1 Jeff Pound 2005-07-21 15:03:56 UTC
Created attachment 117026 [details]
eclipse log file

Comment 2 Jeff Pound 2005-07-22 15:07:56 UTC
The problem appears to be that eclipse can't create a file buffer from files
without extensions. see bug 162447

Comment 3 Tom Tromey 2005-08-18 17:25:24 UTC
FWIW I can't reproduce this with eclipse-platform-3.1.0_fc-6
(I was able to reproduce it with older versions though)
My test case is the Classpath ChangeLog file, though I have edited
several ChangeLog files and other files without extensions successfully.



Comment 4 Andrew Overholt 2005-08-24 14:43:11 UTC
Hmm.  Jeff's finished now so should we close this RAWHIDE?

Comment 5 Tom Tromey 2005-09-09 17:10:10 UTC
This works reliably for me with rawhide eclipse.
I've tried a number of different projects.



Note You need to log in before you can comment on or make changes to this bug.