Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163821 - OOo-1.9.119-1.2.0 segfaults on start
Summary: OOo-1.9.119-1.2.0 segfaults on start
Keywords:
Status: CLOSED DUPLICATE of bug 163930
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 13:53 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-23 14:30:35 UTC


Attachments (Terms of Use)

Description Sammy 2005-07-21 13:53:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.2 (like Gecko)

Description of problem:
After updating via yum all openoffice applications segfaut on start.  
 
========================================================== 
# oocalc 
 
---start copy and paste here--- 
0xe8a959: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e959 
0xe8b15a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f15a 
0x40f420:  + 0x420 (__kernel_sigreturn + 0x0) 
0xbff0d561: ???????? 
0x75f43be: /usr/lib/openoffice.org2.0/program/sysmgr1.uno.so + 0x63be 
(configmgr::backend::BackendRef::getBackend(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> 
const&) + 0x58) 
0x75f4ace: /usr/lib/openoffice.org2.0/program/sysmgr1.uno.so + 0x6ace 
(configmgr::backend::SystemIntegrationManager::getSupportingBackends(rtl::OUString 
const&) + 0x86) 
0x75f4e58: /usr/lib/openoffice.org2.0/program/sysmgr1.uno.so + 0x6e58 
(configmgr::backend::SystemIntegrationManager::listLayers(rtl::OUString const&, 
rtl::OUString const&) + 0x58) 
0x75f3d91: /usr/lib/openoffice.org2.0/program/sysmgr1.uno.so + 0x5d91 
(configmgr::backend::SystemIntegrationManager::listOwnLayers(rtl::OUString const&) + 
0x31) 
0x19524fc: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x8c4fc 
0x19528da: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x8c8da 
0x1950b46: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x8ab46 
0x1940c4b: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x7ac4b 
0x194287d: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x7c87d 
0x19109da: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x4a9da 
0x1912623: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x4c623 
0x19171c6: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0x511c6 
0x19a2774: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0xdc774 
0x19a2393: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0xdc393 
0x19a6433: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0xe0433 
0x19a5824: /usr/lib/openoffice.org2.0/program/configmgr2.uno.so + 0xdf824 
0x22a332: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x35332 
(utl::ConfigManager::AcquireTree(utl::ConfigItem&) + 0x22a) 
0x22a533: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x35533 
(utl::ConfigManager::AddConfigItem(utl::ConfigItem&) + 0x31) 
0x228c89: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x33c89 
(utl::ConfigItem::ConfigItem(rtl::OUString, short) + 0xa5) 
0x529075: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x119075 
(vcl::DefaultFontConfigItem::DefaultFontConfigItem() + 0x37) 
0x5290d5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1190d5 
(vcl::DefaultFontConfigItem::get() + 0x31) 
0x48cd25: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7cd25 
0x48d384: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7d384 
0x48d3b0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7d3b0 
(StyleSettings::StyleSettings() + 0x22) 
0x48eb1f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7eb1f 
0x48ebd3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7ebd3 
(AllSettings::AllSettings() + 0x1f) 
0x490b18: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80b18 
(Application::GetSettings() + 0x30) 
0x4f5c7c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xe5c7c 
(OutputDevice::OutputDevice() + 0x80) 
0x5cdde4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1bdde4 
(Window::Window(unsigned short) + 0x1e) 
0x5b0343: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a0343 
(SystemWindow::SystemWindow(unsigned short) + 0x1f) 
0x5e04b0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d04b0 
(WorkWindow::WorkWindow(unsigned short) + 0x1e) 
0x594a44: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x184a44 
(IntroWindow::IntroWindow() + 0x1e) 
0x554e911: /usr/lib/openoffice.org2.0/program/libspl680li.so + 0xc911 
0x554ec54: /usr/lib/openoffice.org2.0/program/libspl680li.so + 0xcc54 
0x77aa33: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x23a33 
0x77a2ef: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x232ef 
0x77a3a7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x233a7 
0x77aac7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x23ac7 
0x77ac4c: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x23c4c 
0x77bb0c: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x24b0c 
0x7b1b4f0: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x74f0 
0x7b1aeb2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x6eb2 
0x8061f83: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x19f83 
(desktop::Desktop::OpenSplashScreen() + 0xe5) 
0x8064394: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1c394 
(desktop::Desktop::Main() + 0x140) 
0x495bd5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85bd5 (SVMain() + 
0x45) 
0x806077f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1877f (sal_main + 0x47) 
0x7709f2f: /lib/libc.so.6 + 0x14f2f (__libc_start_main + 0xdf) 
0x80606b5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x186b5 
(Window::RequestHelp(HelpEvent const&) + 0x31) 
---end copy and paste here--- 
paste the above into your bug report 
 

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.119-1.2.0.fc5

How reproducible:
Always

Steps to Reproduce:
1. update to 1.9.119-1.2.0 
2. try to start any component 
3. 
   

Additional info:

Comment 1 Todd Mokros 2005-07-22 00:26:02 UTC
I see the same problem.  Wiping out my .openoffice.org2.0 directory lets
openoffice start, but no toolbar icons are shown, and it appears that all icons
are missing (from menus, preferences)

Comment 2 Caolan McNamara 2005-07-23 14:30:35 UTC

*** This bug has been marked as a duplicate of 163930 ***


Note You need to log in before you can comment on or make changes to this bug.