Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163817 - Difference mode runs /etc/profile & bashrc
Summary: Difference mode runs /etc/profile & bashrc
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 12:42 UTC by Michael McLagan
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-06 08:57:00 UTC


Attachments (Terms of Use)
Screen capture showing interrupted gvim session (deleted)
2005-07-21 12:42 UTC, Michael McLagan
no flags Details

Description Michael McLagan 2005-07-21 12:42:08 UTC
Description of problem:
When using difference mode, gvim must execute a shell for unknown reasons
which ends up running the /etc/ scripts,  causing the editing session to 
pause and wait for 'enter' to proceed to display the files.  Alias used is
alias vidiff='/usr/X11R6/bin/gvim -geometry 222x75+0+0 -fn monospace -d'

Version-Release number of selected component (if applicable):
vim-X11-6.3.071-3


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 over working FC3 system
2. Start X session
3. activate vidiff alias with 2 files
  
Actual result:
gvim pauses waiting for 'enter'.

Expected results:
View 2 files with highlighted differences.

Additional info:

Comment 1 Michael McLagan 2005-07-21 12:42:08 UTC
Created attachment 117021 [details]
Screen capture showing interrupted gvim session

Comment 2 Karsten Hopp 2005-09-06 08:57:00 UTC
This looks like your fortune-mod is misbehaving. Have you configured your system
to display fortunes in every newly opened shell ? Please disable that and try again.


Note You need to log in before you can comment on or make changes to this bug.