Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163808 - gcalctool is not using correctly the exponential key when the operators are in arithmetic precedence mode
Summary: gcalctool is not using correctly the exponential key when the operators are i...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 11:28 UTC by Sergio Pascual
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-12 16:29:07 UTC


Attachments (Terms of Use)

Description Sergio Pascual 2005-07-21 11:28:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
In arithmrtic precedence mode I press the exponential key (e^x) and then 1. This should get e to the power of 1, 2.718281845. Instead I get 14!

When I switch to not use the precedence of the operators (ctrl+U), I press 1, then the exponential key and I get the correct result, 2.718281845

Version-Release number of selected component (if applicable):
gnome-utils-2.10.0-3

How reproducible:
Always

Steps to Reproduce:
1. Put the calculator in scientific mode (view menu)
2. Use arithmetic precedence (view menu)
3. Press the exponential key
4. Press 1
5. Press enter

Actual Results:  I get 14 on the display

Expected Results:  I should have get 2.718281845

Additional info:

The calculator works correctly (as far as I know) when the arithmetic precedence mode is disconnected

Comment 1 Sergio Pascual 2006-01-12 10:39:26 UTC
The bug seems to be fixed in gnome-utils-2.10.0-4


Note You need to log in before you can comment on or make changes to this bug.