Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163800 - ICE in EQUIVALENCE between char and array of char
Summary: ICE in EQUIVALENCE between char and array of char
Keywords:
Status: CLOSED DUPLICATE of bug 160853
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 06:06 UTC by Alexander Täschner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-21 08:04:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 18833 None None None Never

Description Alexander Täschner 2005-07-21 06:06:36 UTC
I'm not sure if it is okay to submit a bug which
is known in the GCC Bugzilla (PR 18833), but is
not assigned since seven month.

Anyway here is the bug:

The following code gives an internal error
when compiling with "gfortran equiv.f".
Tested with version 4.0.1-3 but also seen
with older versions.

Error message:
 In file equiv.f:7

      END
                                                                       1
 Internal Error at (1):
 find_array_spec(): Missing spec

--- start of equiv.f ---
      PROGRAM Equiv
      CHARACTER  CQALLC*96
      CHARACTER*1  CQLETT(96), CQNUM(10)
      EQUIVALENCE (CQLETT(1),CQALLC(1:1))
      EQUIVALENCE (CQNUM(1), CQALLC(27:27))

      END
-- EOF ---

Comment 1 Jakub Jelinek 2005-07-21 08:04:00 UTC

*** This bug has been marked as a duplicate of 160853 ***


Note You need to log in before you can comment on or make changes to this bug.