Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163799 - Nautilus cd-burner asking to insert blank disk even though one is already there.
Summary: Nautilus cd-burner asking to insert blank disk even though one is already there.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
: 164747 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 05:24 UTC by Rodd Clarkson
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-04 17:48:12 UTC


Attachments (Terms of Use)
Insert a rewriteable or blank disk dialog (deleted)
2005-07-21 05:24 UTC, Rodd Clarkson
no flags Details
"dmesg" output (deleted)
2005-10-11 23:18 UTC, mark
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 324252 None None None Never

Description Rodd Clarkson 2005-07-21 05:24:25 UTC
Description of problem:

When I try to write to a blank disk, n-cd-burner complains that there is not
rewritable or blank disc in the drive


Version-Release number of selected component (if applicable):

nautilus-cd-burner-2.11.4-1

How reproducible:

Very

Steps to Reproduce:
1. Insert a blank cd (or dvd) into an appropriate device.
2. The CD/DVD Creator window appears.  Drag some files into this.
3. Select File > Write to Disc...
4. Make changes to the "Write to Disc" dialog and click Write.

  
Actual results:

The "Writing files to disc" dialog appears and then another dialog appears
(attached) that asks you to insert a rewritable or blank disc into the drive

Expected results:

The blank disc in the drive should be good enough ;-]

Additional info:

The same thing happens for both blank CD and DVD media.  I was able to burn onto
this media using an earlier version of Fedora (FC4) after having a refusal in
rawhide.

Comment 1 Rodd Clarkson 2005-07-21 05:24:25 UTC
Created attachment 117012 [details]
Insert a rewriteable or blank disk dialog

Comment 2 David Bentley 2005-07-27 17:36:07 UTC
I am getting the same problem both with a fully updated core 4 instalation and 
my test machine which is tracking the developmet tree after a FC4 install.

Comment 3 David Bentley 2005-08-07 14:45:40 UTC
Having done a fresh FTP install on another machine (dual xeon server board Intel
SE7505VB2) yesterday (6/8/05) and found that everthing worked I have spotted
that the systems that don't work mount the blank CD on the desktop as "CD-ROM
Disc" while the system that does work shows the disk on the desktop as "Blank
CD-R Disc".

The other major difference between my three systems is that those which fail were 
either FC4 or converted without update from FC4 to development and the one that
works was done as an FTP install over the internet.

Comment 4 David Bentley 2005-08-10 13:10:11 UTC
See also 164747

Comment 5 mark 2005-10-11 23:18:06 UTC
Created attachment 119822 [details]
"dmesg" output

Comment 6 mark 2005-10-11 23:21:21 UTC
[root@markf78 ~]# rpm -q nautilus-cd-burner
nautilus-cd-burner-2.12.1-1

i am experiencing a similar problem whenever i try to use a DVD+R Dual Layer
disc. single layer discs work correctly but not dual layer discs even though the
gnome website states that this feature was added in the 2.12 release. the icon
appears on the desktop as "dvd+r" and the volume name is "cd-rom disc".

the disc is recognized correctly by dvd+rw tools i.e.

[root@markf78 ~]# dvd+rw-mediainfo /dev/hdc
INQUIRY:                [SONY    ][DVD RW DRU-710A ][BYX4]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         2Bh, DVD+R Double Layer
 Media ID:              RITEK/D01
 Current Write Speed:   2.4x1385=3324KB/s
 Write Speed #0:        2.0x1385=2770KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     2.4x1385=3324KB/s@[0 -> 0]
 Speed Descriptor#0:    00/0 R@2.4x1385=3324KB/s W@2.4x1385=3324KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       E1h, DVD+R DL book [revision 1]
 Legacy lead-out at:    2086912*2KB=4273995776
DVD+R DOUBLE LAYER BOUNDARY INFORMATION:
 L0 Data Zone Capacity: 2086912*2KB, can still be set
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           4173824*2KB
 Track Size:            4173824*2KB
 ROM Compatibility LBA: 262144
READ CAPACITY:          1*2048=2048

i've also confirmed that this problem occurs with dual layer dvd-r discs. i am
willing to provide more info as needed but i wasnt sure whdat else to include. i
attached my "dmesg" output in the previous message. let me know how i can be of
further assistance.

Comment 7 Alexander Larsson 2005-12-16 09:52:13 UTC
*** Bug 164747 has been marked as a duplicate of this bug. ***

Comment 8 Alexander Larsson 2005-12-16 10:07:35 UTC
Its unlikely that I will have time and resources to look into this, but the
upstream maintainer is very good at responding. I filed an upstream bug at:

http://bugzilla.gnome.org/show_bug.cgi?id=324252

I would appreciate if you could help him as much as you can getting this diagnosed.

Comment 9 Rodd Clarkson 2006-01-11 09:42:08 UTC
I'm still seeing this in rawhide, but with:

nautilus-cd-burner-2.13.3-1

Comment 10 Matthias Clasen 2006-08-04 17:48:12 UTC
Supposedly fixed in 2.13.91


Note You need to log in before you can comment on or make changes to this bug.