Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163785 - Text logging for output of pup transaction
Summary: Text logging for output of pup transaction
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 01:55 UTC by Jim Cornette
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-05 02:17:07 UTC


Attachments (Terms of Use)

Description Jim Cornette 2005-07-21 01:55:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050718 Fedora/1.1-0.2.1.deerpark.alpha2 Firefox/1.0+

Description of problem:
After upgrading packages via pup, I encountered conditions where a text output logging facility was desired. I think the logging feature for pup transactiions needs added to the program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. launch pup, allow update transaction to proceed.
2. discover that there is no logging facility for pup output.
3. save a snapshot since no text logs available
  

Actual Results:  downloaded packages before dep resolution. 
encounter dep resolution problem.
click on errors encountered control.
displays errors in dialog box where text could not be retrieved.

Expected Results:  Debatable whether downloading packages before deps is pro or con. It was a pro for me.
This was an expected outcome. Deps were not met in rawhide.
Displaying error where they could be copied to an editor or saved to a file. this would be handy as a save to file feature. A normal log would be acceptable.

Additional info:

This feature is desirable.

Comment 1 Jeremy Katz 2006-01-05 02:17:07 UTC
Fixed in CVS

Comment 2 David Lawrence 2006-06-28 01:43:59 UTC
Moving component to pirut. Sorry for the spam.


Note You need to log in before you can comment on or make changes to this bug.