Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163784 - /etc/sysctl.conf not read during boot
Summary: /etc/sysctl.conf not read during boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-21 01:14 UTC by Andrew Kroeger
Modified: 2014-03-17 02:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-12 19:38:52 UTC


Attachments (Terms of Use)

Description Andrew Kroeger 2005-07-21 01:14:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Added a value for kernel.printk in /etc/sysctl.conf.  Value is not loaded during boot (via /etc/rc.d/init.d/network) but can be successfully loaded after boot using sysctl.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.25.2-4

How reproducible:
Always

Steps to Reproduce:
1. Set a custom value for kernel.printk in /etc/sysctl.conf
2. Reboot
3. Verify value not set using cat /proc/sys/kernel/printk
4. Verify valid entry in /etc/sysctl.conf using sysctl -e -p /etc/sysctl.conf
5. Verify value is set using cat /proc/sys/kernel/printk

Additional info:

Did not find any related entries in /var/log/audit/audit.log.  Upon further checking found auditd does not start until after network.  Given that auditd only logs to a local file, is there any reason it should not be started before all else in runlevel 2?

Comment 1 Daniel Walsh 2005-07-21 15:00:43 UTC
Why did you assign this to SELinux policy?  Shouldn't it be a initscripts
problem?  Are you seeing SELinux failures on the console?

Comment 2 Steve Grubb 2005-08-25 20:16:42 UTC
/var/log/audit may not be a local directory. I start it at the first opportunity
that its safe to do so. Also, chkconfig does not allow you to specify the start
order in a level by level way. If kernel cannot log to auditd, the message will
go to syslog. So, there is a safety net.

If you turn off SE Linux & reboot, does the parameter get loaded? Or maybe you
can do setenforce 0, service network restart, and then check for it. This avoids
needing to relabel the file system.

If not, this looks like initscript problem. Not audit or policy.

Comment 3 Steve Grubb 2005-09-10 16:12:31 UTC
Transferring to initscripts this is not an audit problem.

Comment 4 Bill Nottingham 2005-09-12 19:38:52 UTC
The value that's exported through kernel.printk is reset by syslogd/klogd, which
runs after network is started.


Note You need to log in before you can comment on or make changes to this bug.