Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163771 - I get name_connect denials when trying to browse or chat after updating to kernel 2.6.12-1.1372_FC3
Summary: I get name_connect denials when trying to browse or chat after updating to ke...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL: any remote url
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 22:03 UTC by Randy Heineke
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 16:42:18 UTC


Attachments (Terms of Use)

Description Randy Heineke 2005-07-20 22:03:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The FC3 kernel upgrade package for 2.6.12 add a feature for name_connect permission. This feature is not supported in the latest FC3 package for selinux-policy-targeted.  Would it be possible to get a new FC3 selinux-target-policy package for selinux-policy targeted?

Version-Release number of selected component (if applicable):
selinux-policy-targeted  1.21.14-1

How reproducible:
Always

Steps to Reproduce:
1.Upgrade to FC3 2.6.12.1.1372_FC3 kernel package.
2.With selinux-polic-target 1.21.14-1 installed.
3.Reboot to new kernel.
4.Set selinux security to targeted policy and enabled.
5.Open a browse.
6.Enter a remote URL 
  

Actual Results:  A denied message appears in /var/log/messages

Expected Results:  No log message and a web page should appear

Additional info:

I was planning a migration to FC4 in September.

Comment 1 Daniel Walsh 2005-07-21 00:10:37 UTC
selinux-polic-target 1.21.14-1 is not a valid policy for FC3.

Should be selinux-policy-targeted-1.17.30-3.19?

Looks like you have a partially upgraded machine to FC4.  Not a good idea,
unless you go all the way.


Note You need to log in before you can comment on or make changes to this bug.