Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163763 - mhshow fails to read mhshow-show-text/html from mhn.defaults
Summary: mhshow fails to read mhshow-show-text/html from mhn.defaults
Keywords:
Status: CLOSED DUPLICATE of bug 163760
Alias: None
Product: Fedora
Classification: Fedora
Component: nmh
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Josh Bressers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 21:05 UTC by Joel Uckelman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-20 21:07:50 UTC


Attachments (Terms of Use)

Description Joel Uckelman 2005-07-20 21:05:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

Description of problem:
If I put the following line in /etc/nmh/nmh.defaults:

 mhshow-show-text/html: %plynx -dump -localhost -force_html -noredir '%F' | less

it is ignored and html messages are shown as raw html. But if I put that same line in my ~/.mh_profile, lynx is called and renders the html. I know that the settings in mhn.defaults aren't all being ignored by mhshow, since whether I have

 mhshow-charset-iso-8859-1: %s

there makes a difference when reading messages with that charset.

Version-Release number of selected component (if applicable):
nmh-1.1-8-fc4

How reproducible:
Always

Steps to Reproduce:
1. Get a message which has Content-type: text/html.
2. mhshow

Actual Results:  mhshow displays a bunch of raw html.

Expected Results:  mhshow should call lynx to render the html.

Additional info:

Comment 1 Joel Uckelman 2005-07-20 21:07:50 UTC

*** This bug has been marked as a duplicate of 163760 ***


Note You need to log in before you can comment on or make changes to this bug.