Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163754 - SDL causes BadMatch errors in Metacity with 24-bit color
Summary: SDL causes BadMatch errors in Metacity with 24-bit color
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 163753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 20:21 UTC by Emily Brantley
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 03:46:48 UTC


Attachments (Terms of Use)

Description Emily Brantley 2005-07-20 20:21:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JPM; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
When running any program that uses SDL (frozen-bubble is a good example but not the only one) and X11 display is set to 24-bit color, metacity terminates immediately with BadMatch errors (over and over, since gnome-session tries to restart it over and over).  Changing to 16-bit color, metacity acts fine.

I can try to paste the BadMatch error, if needed.  Should this bug be filed for the SDL component ?  (SDL-1.2.8-3.2)

Version-Release number of selected component (if applicable):
metacity-2.10.2-1

How reproducible:
Always

Steps to Reproduce:
1. run X in 24-bit
2. log in to gnome
3. install and run frozen-bubble

Actual Results:  metacity "crashes" over and over, eventually giving up.  end up window-managerless.

Expected Results:  metacity should remain.

Additional info:

SDL is version SDL-1.2.8-3.2

Comment 1 Ray Strode [halfline] 2005-07-20 20:32:11 UTC
*** Bug 163753 has been marked as a duplicate of this bug. ***

Comment 2 Emily Brantley 2005-07-25 03:46:48 UTC
This isn't a metacity bug, as far as I can tell now.  I took it upon myself to
turn on the Composite extension, which caused this strange turn of events.  I've
turned it off--problem solved.  I'm closing the bug.


Note You need to log in before you can comment on or make changes to this bug.