Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163745 - Simple X programs sometimes come up without a window title bar.
Summary: Simple X programs sometimes come up without a window title bar.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: metacity
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 19:17 UTC by Tom Flynn
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-09 15:10:06 UTC


Attachments (Terms of Use)

Description Tom Flynn 2005-07-20 19:17:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Simple X programs sometimes come up without a window title bar.  This could be related to bug 126571.

Version-Release number of selected component (if applicable):
metacity-2.8.6-2.1

How reproducible:
Sometimes

Steps to Reproduce:
1.Download the sample X tutorial from here:  http://tronche.com/gui/x/xlib-tutorial/xlib-tutorial.tar.gz
2.Compile prog-2 (g++ prog-2.cc -L/usr/X11R6/lib -lX11 -lm -o prog-2)
3.Run prog-2 (./prog-2)
4.A window will come up with a line drawn in it.  The window will stay up for 10 seconds and then exit.
  

Actual Results:  Sometimes the window title bar is missing.  On my machine, it happens about 25% of the time (while filing out this report, I did a trial run and it happened 2 out of 8 runs).  On other machines, I've seen it happen more than half of the time.

Expected Results:  The title bar is always there.

Additional info:

I don't seem to be the only one having this problem.  When googling around to see if anyone else was having the same problems I was having (keywords: title bar missing metacity), I came across the following thread in a mailing list for another piece of software:
https://stat.ethz.ch/pipermail/r-help/2005-February/064549.html

Comment 1 Lars G 2005-08-07 16:46:36 UTC
hi

i have the same problem here after updating to metacity-2.11.1-1 running rawhide.
sometimes an application window comes up without title bar, the app window flashes, 
moves some inches on the screen and then title bar is drawn (but not always).
annoying.

Comment 2 Rodd Clarkson 2005-08-08 23:32:44 UTC
Ah, this looks like it's been fixed in 2.11.2.  Any chance of getting this into
rawhide sooner than later?

From the release notes:

- Fix an easy to trigger crasher in 2.11.1 caused by unneeded
   debugging spew (Elijah) [#311819]

That bug reference will of course be for bugzilla.gnome.org.

Comment 3 Ray Strode [halfline] 2005-08-09 14:53:18 UTC
Sure

Comment 4 Ray Strode [halfline] 2005-08-09 15:10:06 UTC
Should be in tomorrow's rawhide.

Comment 5 Lars G 2005-08-10 18:16:59 UTC
todays rawhide update fixed it for me.
thanks!


Note You need to log in before you can comment on or make changes to this bug.