Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163715 - RFE: add incremental backup functionality
Summary: RFE: add incremental backup functionality
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pax
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 16:10 UTC by Patrick C. F. Ernzer
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-06 11:55:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2005-07-20 16:10:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
As per BZ #163683.

It would be nice if pax supported the incremental backup functionality that tar supports. This will allow using it with amanda

Version-Release number of selected component (if applicable):
pax-3.0-9

How reproducible:
Didn't try

Steps to Reproduce:
1. use amanada to backup a machine that uses SELinux
2. find out that amanda uses tar which does not support EAs and ACLs
3. try to find an alternative to tar for amanda to use

Actual Results:  pax is lacking required functionality

Expected Results:  pax being usable with amanda

Additional info:

Comment 1 Patrick C. F. Ernzer 2005-07-20 16:16:12 UTC
BZ #163716 has been also opened requesting the same from pax.

IIRC the consensus on tech-list was that while both star and pax are not
perfect, pax is preferable.

Comment 2 Peter Vrabec 2005-08-03 15:29:10 UTC
Do u think pax is good alternative? It doesn't support EAs and ACLs, does it.

Comment 4 Peter Vrabec 2006-09-06 11:55:32 UTC
Patrick, I think this bug is not relevant since we have star and tar>=1.15.90-6 with incremental 
backup functionality and EAs and ACLs support. It would be significant amount of work to add 
this functionality to pax.



Comment 5 Patrick C. F. Ernzer 2006-09-06 13:01:09 UTC
Peter,

fair enough if tar>=1.15.90-6 now supports EAs and ACLs the aim of having our
amanda package making a real backup again (i.e. with EA and ACL) is fulfilled.

Will 1.15.90-6 that go into RHEL5 (Beta 1 of it still has 1.15.90-5)?

Comment 6 Peter Vrabec 2006-09-06 14:42:18 UTC
It was build on Aug 10 2006, so I guess it should be there


Note You need to log in before you can comment on or make changes to this bug.