Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163710 - unable to rebuild evolution package - bad spec file logic
Summary: unable to rebuild evolution package - bad spec file logic
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 15:57 UTC by Eugene Kanter
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: 2.0.2-16.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-14 15:33:40 UTC


Attachments (Terms of Use)

Description Eugene Kanter 2005-07-20 15:57:25 UTC
evolution-2.0.2-16.src.rpm

Description of problem:

evolution has an implicit build dependency on the mozilla package which version
is listed in %define mozilla_build_version x.x.x. However down in BuildRequies
it says

BuildRequires: mozilla-nspr-devel >= 37:%{mozilla_build_version}
BuildRequires: mozilla-nss-devel  >= 37:%{mozilla_build_version}

This means that if mozilla is updated to a next version evolution build will
start but then fail because of 

if [ ! -f /usr/include/mozilla-%{mozilla_build_version}/nspr/nspr.h ]; then
  echo "Unable to find suitable version of mozilla nss to use!"
  exit 1

The spec file must be made flexible enough to avoid the conflict.

Comment 1 Andy Shevchenko 2005-09-23 08:34:03 UTC
2.0.2-16.3 has included that definition.

Dave, why do you not close this bug?


Comment 2 Bastien Nocera 2006-08-14 15:33:40 UTC
Closing as per last comment. Thanks Andy for the notice.


Note You need to log in before you can comment on or make changes to this bug.