Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163702 - cpuspeed needs man page
Summary: cpuspeed needs man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jarod Wilson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 14:57 UTC by Brian Long
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0282
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-07 23:32:36 UTC


Attachments (Terms of Use)
Proposed man page (deleted)
2005-12-06 19:19 UTC, Brad Hinson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0282 normal SHIPPED_LIVE kernel-utils bug fix update 2007-04-28 18:37:26 UTC

Description Brian Long 2005-07-20 14:57:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
All the utilities included in kernel-utils except cpuspeed has a man page.  Please take the output of cpuspeed -h and put it in man format so I can run "man cpuspeed".

Version-Release number of selected component (if applicable):
kernel-utils-2.4-13.1.66

How reproducible:
Always

Steps to Reproduce:
1. man cpuspeed


Actual Results:  No manual entry for cpuspeed

Expected Results:  cpuspeed -h
cpuspeed v1.1b

This program monitors the system's idle percentage and reduces or raises the
CPU clock speed and voltage accordingly to minimize power consumption when
idle and maximize performance when needed.  This is the default behavior.

The program can also be configured to reduce the CPU clock speed if the CPU
temperature gets too high or if the computer's AC adapter is disconnected.

Usage: cpuspeed [Options]

    Options:
        -d
            Tells the process to daemonize itself (run in background).

        -i <interval>
            Sets the interval between idle percentage tests and possible
            speed changes in 1/10 second increments (default is 20).

        -p <fast up> <threshold>
            Sets the CPU idle percentage thresholds.  <fast up> is the idle
            percentage below which the CPU will be set to the highest possible
            speed.  <threshold> is the idle percentage above which the CPU
            speed will be decreased and below which the CPU speed will be
            increased (defaults are 10 and 25).

        -t <temp file> <maxtemp>
            Sets the ACPI temperature file and the temperature at which CPU
            will be set to minimum speed.

        -a <AC file>
            Sets the ACPI AC adapter state file and tells the program to set
            the CPU to minimum speed when AC adapter is disconnected.

    To tell the program to stay at the highest CPU clock speed to maximize
    performance, send the process the SIGUSR1 signal.

    To tell the program to stay at the lowest CPU clock speed to maximize
    battery life, send the process the SIGUSR2 signal.

    To tell the program to go back to scaling the CPU clock speed dynamically,
    send the process the SIGHUP signal.

Example:
    cpuspeed -d -i 10 -t /proc/acpi/thermal_zone/THRM/temperature 79 \
        -a /proc/acpi/ac_adapter/ACAD/state

    This will have the program check (and possibly change) the CPU speed once
    every second and go to minimum CPU speed if the temperature goes above 79
    or the AC adapter is disconnected.

Author:
    Carl Thompson <cet@carlthompson.net>


Additional info:

Comment 2 Brad Hinson 2005-12-06 19:19:33 UTC
Created attachment 121942 [details]
Proposed man page

Comment 6 Daniel Riek 2006-08-28 21:53:23 UTC
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this request by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This request is not yet committed for inclusion in an Update release. 

Comment 7 Leon Ho 2006-09-05 08:17:33 UTC
Received this bug on 1st of Sep for LingNing. 

Should be easy for updating an errata for kernel-utils. Dave, since you are the
maintainer of kernel-utils, is it a package that LingNing can update in RHEL4.5?

Comment 10 Jarod Wilson 2007-01-15 15:26:40 UTC
A cpuspeed manpage based on 'cpuspeed --help' output is now included as of
kernel-utils-2.4-13.1.97.

Comment 14 Red Hat Bugzilla 2007-05-07 23:32:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0282.html


Note You need to log in before you can comment on or make changes to this bug.