Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163684 - Firefox File->Print generates invalid PostScript (invalid "BoundingBox")
Summary: Firefox File->Print generates invalid PostScript (invalid "BoundingBox")
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 163676 163677 163678 163679 163680 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 09:36 UTC by James Hunt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-21 22:24:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 301631 None None None Never

Description James Hunt 2005-07-20 09:36:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Firefox seems to be generating invalid PostScript that causes 'gv' to crash, and gsview to display nasty error messages about "BoundingBox".

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
Always

Steps to Reproduce:
1. Select a web page
2. Print it to a file
3. Attempt to view the PostScript file using 'gv' or 'gsview'
  

Actual Results:  'gv' crashes like this:

> gv mozilla.ps 
Warning: Representation size 4 must match superclass's to override highlightedBackground
Warning: Unsupported shape style for Command widget "toggleCurrent"
Warning: Unsupported shape style for Command widget "toggleEven"
Warning: Unsupported shape style for Command widget "toggleOdd"
Warning: Unsupported shape style for Command widget "unmarkAll"
Warning: Unsupported shape style for Command widget "autoResize"
Warning: Representation size 2 must match superclass's to override internalWidth
Violaci�n de segmento (core dumped)

'gsview mozilla.ps' displays an error box containing this text:

DSC Warning at line 2:
  %%BoundingBox: 0 0 595.25 841.9
This line is incorrect.
The bounding box must be in integer coordinates,
not floating point. A floating point bounding box should
be specified using %%HiResBoundingBox:
A %%BoundingBox: should still be provided with Integer values.


Expected Results:  The file should have displayed as normal in both gv and gsview.

Additional info:

I've tried lots of web pages - all seem generate the same errors.

Here is the header for the erroneous firefox-generated PostScript file:

%!PS-Adobe-3.0
%%BoundingBox: 0 0 595.25 841.9
%%Creator: Mozilla PostScript module (rv:1.7.8/2005052423)
%%DocumentData: Clean8Bit
%%DocumentPaperSizes: A4
%%Orientation: Portrait
%%Pages: (atend)
%%PageOrder: Ascend
%%EndComments
% MozillaCharsetName: iso-8859-1

Here are the 'gv' and 'gsview' versions:

> rpm -q gv
gv-3.5.8-29

> rpm -q gsview
gsview-4.6-10

Comment 1 Bill Nottingham 2005-07-21 04:06:49 UTC
*** Bug 163677 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2005-07-21 04:06:54 UTC
*** Bug 163676 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-07-21 04:07:12 UTC
*** Bug 163678 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2005-07-21 04:07:15 UTC
*** Bug 163679 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2005-07-21 04:07:37 UTC
*** Bug 163680 has been marked as a duplicate of this bug. ***

Comment 6 James Hunt 2005-07-21 09:50:16 UTC
Todays update to firefox-1.0.6-1.1.fc4 doesn't fix the problem.

Comment 7 Christopher Aillon 2005-07-21 22:24:13 UTC
That's because I didn't do anything with this bug yet.

Just filed this upstream as https://bugzilla.mozilla.org/show_bug.cgi?id=301631


Note You need to log in before you can comment on or make changes to this bug.