Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163672 - panic on boot with kernel-2.6.12-1.1372_FC3 due to insmod failure.
Summary: panic on boot with kernel-2.6.12-1.1372_FC3 due to insmod failure.
Keywords:
Status: CLOSED DUPLICATE of bug 163437
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 08:06 UTC by Martin Garton
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-21 14:12:04 UTC


Attachments (Terms of Use)

Description Martin Garton 2005-07-20 08:06:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
after installing kernel-2.6.12-1.1372_FC3, boot fails with:

insmod: error inserting /lib/ata_piix.ko: -1 unknown symbol in module
ERROR: /bin/insmod exited abnormally!
    Reading all physical volumes. .This may take a while...
umount /sys failed: 16
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!

(note - this was copied doen by hand so may not be 100% correct)


reverting to kernel-2.6.11-1.35_FC3 allowed boot no problem.


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
try to boot with kernel-2.6.12-1.1372_FC3

Actual Results:  panic described above.

Expected Results:  normal boot.

Additional info:

This is a dell optiplex gx280.  Hyperthreading is enabled and I am using the SMP kernel.

/sbin/lspci says:

00:00.0 Host bridge: Intel Corp. 915G/P/GV Processor to I/O Controller (rev 04)
00:01.0 PCI bridge: Intel Corp. 915G/P/GV PCI Express Root Port (rev 04)
00:02.0 VGA compatible controller: Intel Corp. 82915G Express Chipset Family Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corp. 82915G Express Chipset Family Graphics Controller (rev 04)
00:1c.0 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corp. 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corp. 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)

Comment 1 Mike Iglesias 2005-07-20 17:05:36 UTC
I'm seeing the same thing on a dual P3 system with disks on a SCSI adapter (no
insmod messages during boot).  The SMP kernel will not boot, but the UP kernel
does as does the 2.6.11-1.35 SMP kernel.  I mv'd modprobe.conf and hwconf and
reran kudzu before installing 2.6.12-1.1372.  /etc/modprobe.conf contains
a line for the SCSI adapter (alias scsi_hostadapter aic7xxx) along with the
other devices (sound and ethernet).


Comment 2 Lyman Byrd 2005-07-21 12:23:40 UTC
I also have a failure on booting but my problem is:
insmod: Error inserting '/lib/sata_Promise.ko': -1 unknown symbol in module.
Error: /sbin/udevstart exited abnormally
unable to find device-mapper major/minor
blah blah blah..
I am also booting the smp kernel because I have dual zeon processors. I have not
tried booting the non smp kernel but when I drop back to the 2.6.11-1.35_fc3smp
kernel I have not problems. 

Comment 3 Frank Ch. Eigler 2005-07-21 14:12:04 UTC

*** This bug has been marked as a duplicate of 163437 ***


Note You need to log in before you can comment on or make changes to this bug.