Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163665 - firefox doesn't start on x86_64
Summary: firefox doesn't start on x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 03:10 UTC by Alexandre Oliva
Modified: 2009-01-19 14:39 UTC (History)
2 users (show)

Fixed In Version: firefox-1.1-0.2.3.deerpark.alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 20:16:36 UTC


Attachments (Terms of Use)
strace -f firefox-bin, as called by run-mozilla.sh (deleted)
2005-07-20 06:04 UTC, Alexandre Oliva
no flags Details
diff from previous strace to run with LD_LIBRARY_PATH=/usr/X11R6/lib64 (deleted)
2005-07-20 06:06 UTC, Alexandre Oliva
no flags Details

Description Alexandre Oliva 2005-07-20 03:10:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050715 Fedora/1.7.8-6

Description of problem:
Running firefox on a FC devel x86_64 box as of 2005-07-19 completes almost immediately, even if ~/.mozilla/firefox does not exist to begin with, and no mozilla or firefox window is open.  After the firefox script terminates, no firefox-related process is running, and ~/.mozilla/firefox was created.

My firefox profile works fine on an i686 box with an FC devel just as up-to-date works fine.  Running firefox on remote displays works or fails to work the same as on local displays, e.g., if I ssh from the i686 box to the x86_64 box and start firefox in it, it won't work; if I do it the other way round, then it works fine.

I tried installing only the 32-bit version of firefox on the x86_64 box, removing the 64-bit version, but, oddly, this one wouldn't start either.

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.1.deerpark.alpha2

How reproducible:
Always

Steps to Reproduce:
1.Run `firefox' from the command line, or start it from the menus or panels, on an x86_64 box

Actual Results:  Nothing happens

Expected Results:  It should start like it does on i686

Additional info:

Comment 1 Christopher Aillon 2005-07-20 03:13:23 UTC
Got a gdb backtrace and/or strace?

Comment 2 Alexandre Oliva 2005-07-20 06:04:48 UTC
Created attachment 116965 [details]
strace -f firefox-bin, as called by run-mozilla.sh

No gdb trace, since it doesn't crash; it terminates normally.

I'm attaching an strace of firefox-bin, with the arguments and environment
passed to it by run-mozilla.sh (I added the strace call to run-mozilla.sh).

Comment 3 Alexandre Oliva 2005-07-20 06:06:33 UTC
Created attachment 116966 [details]
diff from previous strace to run with LD_LIBRARY_PATH=/usr/X11R6/lib64

I noticed the previous run didn't find libXcursor.so, so I added
LD_LIBRARY_PATH=/usr/X11R6/lib64, but, although this time it found the lib,
that didn't make much of a difference, as the strace diff shows.

Comment 4 Alexandre Oliva 2005-07-20 18:25:50 UTC
An interesting data point: if there is a running firefox on the active display
(e.g., started on a remote x86 box), running the broken x86_64 firefox succeeds
in requesting the running firefox to open a given URL.  So it's not *all* broken.

Comment 5 Alexandre Oliva 2005-07-22 12:26:13 UTC
After updating to 20050721's firefox-1.1-0.2.3.deerpark.alpha2 and rebooting, it
started in x86_64 again.  Not sure whether it was the update or the reboot, but
it's fixed.

Comment 6 Christopher Aillon 2005-07-22 17:19:36 UTC
Cool.  Wonder if this was a duplicate of bug 163653 then.

Comment 7 Alexandre Oliva 2005-07-23 12:44:13 UTC
I may have run into that as well, but when I first ran into the problem, I tried
even moving my ~/.mozilla out of the way, to get a fresh start, and that didn't
help.

Comment 8 sean 2005-07-26 18:35:21 UTC
Still doesn't work for me:

[system@amd64-3000 firefox-1.1]$ firefox
[system@amd64-3000 firefox-1.1]$ ./firefox-bin
./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open
shared object file: No such file or directory
[system@amd64-3000 firefox-1.1]$ ls -l libmozjs.so
-rwxr-xr-x  1 root root 673216 Jul 23 02:27 libmozjs.so
[system@amd64-3000 firefox-1.1]$ rpm -q firefox
firefox-1.1-0.2.4.deerpark.alpha2


Comment 9 Christopher Aillon 2005-07-26 20:16:36 UTC
Your issue appears different than the original issue that was reported, though
the end result is the same.  Please file a new bug?  That way we can better
track the different issues.  Thanks.

Comment 10 sean 2005-07-27 03:53:36 UTC
Ok. entered as 164341.


Note You need to log in before you can comment on or make changes to this bug.