Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163662 - Mounting a blank CDRW causes system to hang
Summary: Mounting a blank CDRW causes system to hang
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-20 02:06 UTC by Peter Cook
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-20 21:24:53 UTC


Attachments (Terms of Use)

Description Peter Cook 2005-07-20 02:06:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I inserted a blank CDRW then typed:

mount /dev/cdrom /media/cdrecorder

Then the system hung.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Insert blank CDRW
2.In terminal type: mount /dev/cdrom /media/cdrecorder

  

Actual Results:  The system hangs and I must hard reboot.

Expected Results:  Warning message should appear that blank CDRW can't be mounted.

Additional info:

I know it doesn't make sense to mount a blank CD however I stumbled across this bug by accident while using the usermount GUI (System Tools - Disk Management...same results as using mount command) and trying to copy a CD. Unfortunately the accident caused me to reboot. I shouldn't have to reboot.

Comment 1 Peter Cook 2005-07-20 02:09:35 UTC
I noticed that when I was asked to initially choose a component the instructions
said that if the component you were reporting a bug on was not in the list to
choose the closet component and add some comments to the description field. I
added comments to explain that "diskcheck" was not the correct component, but I
don't see those comments anywhere in this bug report. ???

Comment 2 Andre Robatino 2005-07-20 13:30:41 UTC
  Which kernel are you using?  This bug was considered fixed with the latest
2.6.12-1.1398_FC4 kernel.

Comment 3 Peter Cook 2005-07-20 21:24:53 UTC
I was using 2.6.12-1.1390, but I upgraded to 1398 and the problem is resolved.
Thanks!


Note You need to log in before you can comment on or make changes to this bug.