Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163653 - Firefox crashes due to file:/// URLs in the 'Personal Toolbar'
Summary: Firefox crashes due to file:/// URLs in the 'Personal Toolbar'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 163698 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 21:07 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 1.1-0.2.3.deerpark.alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-21 15:05:19 UTC


Attachments (Terms of Use)
test-case bookmarks.html (deleted)
2005-07-19 21:07 UTC, Michael Schwendt
no flags Details
backtrace! (deleted)
2005-07-20 16:59 UTC, Bill Nottingham
no flags Details
strace (deleted)
2005-07-21 13:00 UTC, Brian Gerst
no flags Details

Description Michael Schwendt 2005-07-19 21:07:19 UTC
Description of problem:
Firefox crashes immediately at startup when the attached bookmarks.html file is
in my default profile directory. When I delete the file, Firefox starts fine.
When I put back the file, it doesn't start anymore.

Version-Release number of selected component (if applicable):
$ rpm -q firefox
firefox-1.1-0.2.1.deerpark.alpha2


How reproducible:
Always. Started with a much bigger bookmarks file, took out many entries until I
found a tiny test-case which still makes Firefox crash reproducibly. Only one
URL is bookmarked in this file.

I hope it's reproducible also for you with this attachment.

Comment 1 Michael Schwendt 2005-07-19 21:07:20 UTC
Created attachment 116946 [details]
test-case bookmarks.html

Comment 2 Bill Nottingham 2005-07-20 16:10:52 UTC
I've reproduced this with my bookmarks.

AFAICT, it's due to having a file:/// link in the bookmarks. Changing summary.


Comment 3 Bill Nottingham 2005-07-20 16:59:55 UTC
Created attachment 116986 [details]
backtrace!

Comment 4 Christopher Aillon 2005-07-20 17:33:39 UTC
All signs point to firefox-1.1-uriloader.patch
Sigh.

Comment 5 Christopher Aillon 2005-07-21 03:24:56 UTC
firefox-1.1-0.2.3.deerpark.alpha2 has the fix.

Comment 6 Bill Nottingham 2005-07-21 04:03:00 UTC
Yup, fix works for me.

Comment 7 Ola Thoresen 2005-07-21 12:17:09 UTC
Does not work here:

[olen@ws21 ~]$ rpm -q firefox
firefox-1.1-0.2.3.deerpark.alpha2
[olen@ws21 ~]$ firefox
[olen@ws21 ~]$
[olen@ws21 ~]$ /usr/lib64/firefox-1.1/run-mozilla.sh

run-mozilla.sh: Cannot execute .

[olen@ws21 ~]$
[olen@ws21 ~]$ /usr/lib64/firefox-1.1/firefox-bin
/usr/lib64/firefox-1.1/firefox-bin: error while loading shared libraries: 
libmozjs.so: cannot open shared object file: No such file or directory
[olen@ws21 ~]$ ls -la /usr/lib64/firefox-1.1/libmoz*
-rwxr-xr-x  1 root root 673216 Jul 21 05:29 /usr/lib64/firefox-1.1/libmozjs.so
[olen@ws21 ~]$ uname -rp
2.6.12-1.1435_FC5 x86_64



Comment 8 Brian Gerst 2005-07-21 13:00:34 UTC
Created attachment 117023 [details]
strace

firefox-1.1-0.2.3.deerpark.alpha2.x86_64 still does not work for me, strace
attached.

Comment 9 Bill Nottingham 2005-07-21 15:05:19 UTC
Ola/Brian: I'm reclosing it - you're seeing bug 163665, not this bug.

Comment 10 Rahul Sundaram 2005-09-04 23:13:20 UTC
*** Bug 163698 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.