Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163644 - Setting error_reporting doesn't turn off strict warning messages
Summary: Setting error_reporting doesn't turn off strict warning messages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://bugs.php.net/bug.php?id=33762
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 19:48 UTC by Russell McOrmond
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 09:49:10 UTC


Attachments (Terms of Use)

Description Russell McOrmond 2005-07-19 19:48:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I tried to file this bug with the PHP team, but they claim it is some patch that Fedora adds that would be the cause of the problem.

Full description is in the PHP bug.

I am currently running the PHP version from FC3 whie this problem with PHP5 gets resolved.  There are many scripts that would output these warnings, and the inability to turn these "strict warning" messages off made PHP5 unuseable.

The site that had the obvious problem is a Drupal 4.5 site.

Version-Release number of selected component (if applicable):
php-5.0.4-10.3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. Install Drupal 4.5
3. Regardless of the settings of error_reporting various "strict warning" are output
  

Additional info:

Comment 1 Russell McOrmond 2005-07-19 19:52:16 UTC
Woops -- Step 1 should say "Install FC4".  The version of PHP that comes with
FC3 works with these scripts fine.  PHP4 doesn't have strict warnings as this is
a new feature with PHP5.


Comment 2 Joe Orton 2005-07-19 20:18:08 UTC
Can you provide an example page which shows the problem?

Comment 3 Russell McOrmond 2005-07-19 20:38:09 UTC
I can't at the moment set up a demonstration site.  I am mostly unavailable this
week (At http://www.linuxsymposium.org ) to set up a separate machine with FC4
and Drupal.  I needed to put the machine where I noticed the error back to an
older version as some important sites run from that machine that I can't keep
down while I test.

If you are unable to set up a test environment, I will do so here.

Comment 4 Joe Orton 2005-07-26 09:49:10 UTC
As far as I can tell this is just a problem with the Drupal 4.5 error handling.
 There are no patches to error handling in the Fedora PHP 5.0.4 package.

http://www.hivemindz.com/getting_drupal_4_5_to_work_using_php5

Comment 5 Russell McOrmond 2005-07-28 20:20:22 UTC
Just to confirm, this was an issue with the error handler set via
set_error_handler('error_handler'), and not a problem with PHP configuration. 
Sorry for submitting this bug...

Thanks.



Note You need to log in before you can comment on or make changes to this bug.