Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163617 - Instaler hangs when informing the kernel about modifications to partition (parted exception)
Summary: Instaler hangs when informing the kernel about modifications to partition (p...
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 15:17 UTC by Valdemir C silva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 04:02:37 UTC


Attachments (Terms of Use)
Dump from floppy following installer crash (deleted)
2005-07-23 05:15 UTC, Jonathan Gowland
no flags Details

Description Valdemir C silva 2005-07-19 15:17:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Instaler hangs when informing the kernel about modifications to partition  (parted exception).
At install window:
Traceback...
File /usr/bin.anaconda line 1160 in intf.run(id,dispatch)
File /usr/lib/anconda/text.py line 496 in run disoatch.gotonext()
File /usr/lib/anconda/dispatch.py line 174 in gotoNext self.moveStep()
File /usr/lib/anconda/dispatch.py line 242 in moveStep rc= apply(func,self.bindArgs(args))
File /usr/lib/anconda/patitioning.py line 121 in artitioningComplete diskSet.savePArtitions ()
File /usr/lib/anconda/partedUtils.py line 726 in savePartitions disk.commit()

error: Error: Error informing the kernelabout modifications to aprtition /dev/hda1
- Device or resource busy. This means Linux won't know about any changes you amde to /dev/hda1 until you reboot - so you shouldn't mount it oruse it in any way before rebooting.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Jonathan Gowland 2005-07-23 05:15:36 UTC
Created attachment 117095 [details]
Dump from floppy following installer crash

Experience is similar to original bug report.

Comment 2 Jeremy Katz 2005-07-26 04:02:37 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.