Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163608 - ia64: Unaligned accesses are made when NFS starts
Summary: ia64: Unaligned accesses are made when NFS starts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 5
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2005-07-19 14:23 UTC by Prarit Bhargava
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-24 18:12:16 UTC


Attachments (Terms of Use)

Description Prarit Bhargava 2005-07-19 14:23:42 UTC
Description of problem:

Unaligned accesses are made when NFS starts on ia64.

Version-Release number of selected component (if applicable):

Fedora ia64 devel, rawhide-20050719
nfs-utils-1.0.7-8

How reproducible: 100%

Steps to Reproduce:

1. Install latest Fedora ia64 devel
2. Boot.
  
Actual results:

When starting NFS the following errors are seen:

Starting NFS statd: kernel unaligned access to 0xe00000b00487fce4,
ip=0xa000000100545391
kernel unaligned access to 0xe00000b00487fce4, ip=0xa000000100545450
[  OK  ]
kernel unaligned access to 0xe00000b00487fce4, ip=0xa000000100545391
kernel unaligned access to 0xe00000b00487fce4, ip=0xa000000100545450

Expected results:

No errors should be seen.

Additional info:

I think I had put in an earlier bug on this on another RH product (I can't
recall the BZ#).  If memory serves the issue is that nfs-utils needs to built
with the -ftz compile flag.

Comment 1 Prarit Bhargava 2005-07-20 20:14:04 UTC
The ftz flag reference above is a mistake -- I was thinking of another issue ...

P.

Comment 3 Dave Anderson 2005-09-01 13:55:20 UTC
Sure sounds familiar to RHEL3, where someplace in the NFS code was accessing
a packed data structure.  The text locations of the IP addresses reported above
would at least nail the offender.

Comment 4 Steve Dickson 2006-07-24 18:12:16 UTC
I believe this has been fixed in later kernels (at least I have
not seen this problem lately).... If this is not the case please
reopen... 


Note You need to log in before you can comment on or make changes to this bug.