Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163592 - system config-bind can't be build when bind isn't installed
Summary: system config-bind can't be build when bind isn't installed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 10:54 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 00:04:50 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2005-07-19 10:54:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
system-config-bind runs the following scriptlet during %install:

for f in *.py ; do                                                           \
  mkdir -p /var/tmp/system-config-bind-4.0.0-19_FC5-root/usr/share/system-config-bind;                                   \
  install -p -o root -g named -m 0754 *.py *.py[co] system-config-bind.glade /var/tmp/system-config-bind-4.0.0-19_FC5-root/usr/share/system-config-bind;  \
done


This fails if bind isn't installed because there's no group 'named':
install: invalid group `named'

Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-19_FC5

How reproducible:
Always

Steps to Reproduce:
1.rpm -e bind
2.make sure 'named' isn't in /etc/group anymore
3.rebuild package
  

Additional info:

Comment 1 Jason Vas Dias 2005-07-19 20:31:28 UTC
OK, 'BuildRequires: bind' is now committed to the s-c-b .spec file for inclusion
in the next release; it has always had 'Requires: bind, bind-utils'.
The idea is that the executable components get installed with ownership 
root:named, mode 754, so that only root and members of the named group
can run s-c-b (only they have write access to named.conf & zone files).



Note You need to log in before you can comment on or make changes to this bug.