Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163591 - Bad font substitutions
Summary: Bad font substitutions
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 10:42 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.122-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-08 08:27:35 UTC


Attachments (Terms of Use)
havecrushonyou.TTF (deleted)
2005-07-19 10:42 UTC, Tim Waugh
no flags Details
example source (deleted)
2005-07-19 13:16 UTC, Caolan McNamara
no flags Details

Description Tim Waugh 2005-07-19 10:42:42 UTC
Description of problem:
With the test update of openoffice.org, font substitutions are handled very
badly.  This is a regression since 1.9.112-1.1.0.fc4.

Version-Release number of selected component (if applicable):
1.9.117-2.1.0.fc4

How reproducible:
100%

Steps to Reproduce:
1. Install the attached font
2. Start oowriter
3. Type something

Actual results:
Default font is "I used to have a crush on you".

Expected results:
Default font is something a bit more normal!

Additional info:
This font is also substituted for "Times New Roman".

Comment 1 Tim Waugh 2005-07-19 10:42:42 UTC
Created attachment 116918 [details]
havecrushonyou.TTF

Comment 2 Caolan McNamara 2005-07-19 13:16:50 UTC
Created attachment 116926 [details]
example source

source to reproduce this substitution

Comment 3 Caolan McNamara 2005-07-19 13:22:13 UTC
perhaps bug 163147 is related.

caolanm->davidz: our OOo uses font-config to find font substitutions, OOo can
only use outline fonts so I make a subset of the available fonts and create a
config of outline only. Then with the above font installed the sample code
attached gives the new font as it's best substitution. Can you have a look and
see if there's a solution ?

Comment 4 Caolan McNamara 2005-08-05 15:07:46 UTC
caolanm->twaugh: is this still the case with 1.9.122-3 ?

Comment 5 Tim Waugh 2005-08-08 08:23:52 UTC
I installed this package on FC4:

openoffice.org-core-1.9.122-4.2.0.fc5

and that seems to fix the problem, yes.

Comment 6 Caolan McNamara 2005-08-08 08:27:35 UTC
alternative fontconfig stuff seems to avoid this problem them. Fixed rawhide,
and we'll push a fc4 update in the next week or two.


Note You need to log in before you can comment on or make changes to this bug.