Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163575 - XMLRPC interface for adding external bug associations
Summary: XMLRPC interface for adding external bug associations
Keywords:
Status: CLOSED DUPLICATE of bug 725627
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 3.6
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: Simon Green
QA Contact: Kevin Baker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 03:14 UTC by Roland McGrath
Modified: 2014-12-01 23:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-10 12:24:06 UTC


Attachments (Terms of Use)

Description Roland McGrath 2005-07-19 03:14:47 UTC
Description of problem:

There should be a scriptable way to add to a bug the association with an
external bug identifier, as can be done from the web interface.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Roland McGrath 2007-11-20 21:54:20 UTC
Is this something that will come with 3.0?  I don't even remember wanting this
in particular (I've never used XMLRPC).  I'm sure it was what dkl told me to
file after discussing ideas about automatic bug escalation between RH and
sourceware bugzilla.

Comment 2 David Lawrence 2007-11-20 22:32:45 UTC
Sorry for the long delay in responding this report :( Yes, this functionality
should come with the 3.0 upgrade since the backend code will be improved enough
to allow changing of all bug attributes through a single XMLRPC call. Currently
we have hacked ours to have different methods to change individual attributes
and unfortunately external bug references is not one of them currently. Let me know
if you need this sooner than the 3.0 timeframe and maybe we can add the support in.

Dave

Comment 3 Roland McGrath 2007-11-20 22:48:07 UTC
I don't need an XMLRPC feature myself ever, certainly not by any particular
deadline.  My interest is in having you implement cool features for cooperation
between this bugzilla and upstream bugzillas, whenever and however that can happen.

Comment 4 David Lawrence 2008-09-16 16:53:02 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 5 David Lawrence 2010-01-15 17:32:41 UTC
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.

Comment 6 David Lawrence 2010-08-25 21:43:00 UTC
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team

Comment 8 Simon Green 2012-05-10 12:24:06 UTC

*** This bug has been marked as a duplicate of bug 725627 ***


Note You need to log in before you can comment on or make changes to this bug.