Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163565 - oowriter crashes when you try and create a document
Summary: oowriter crashes when you try and create a document
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 22:59 UTC by Alan Cox
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 23:30:35 UTC


Attachments (Terms of Use)

Description Alan Cox 2005-07-18 22:59:17 UTC
Description of problem:
Start oowriter, hit new/text document on the menu, admire crashdump

0x4d6b0a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db0a
0x4d7358: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e358
0xffffe500:  + 0x500 (__kernel_sigreturn + 0x0)
0xf43d2738: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xc7738
0xf43b517b: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xaa17b
0xf43b5e95: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xaae95
0xf43b70a4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xac0a4
0xf43bb42c: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xb042c
0xf43e6297: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xdb297
0xf43c16f4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xb66f4
0xf43974f2: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x8c4f2
0xf43ab0ff: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xa00ff
0xf47bb3d1: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1203d1
0xf47fe8af: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1638af
0xf482b7dc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1907dc
0xf482ce3d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x191e3d
0xf474575d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xaa75d
(SfxApplication::SetViewFrame(SfxViewFrame*) + 0x235)
0xf48108fa: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1758fa
0xf4811060: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x176060
(SfxViewFrame::Show() + 0x14e)
0xf481e040: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x183040
(SfxTopFrame::InsertDocument(SfxObjectShell*) + 0x814)
0xf4736ea4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9bea4
0xf4800e85: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x165e85
0xf43eb4b2: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe04b2
0xf43eb675: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe0675
0xf4344ad1: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x39ad1
0xf4344733: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x39733
0xf44431db: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1381db
0xbea4e2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x824e2
0xd3e8cf: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d68cf
0xf7c5511c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x2211c
0xf7c7a27b: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4727b
(SalDisplay::DispatchInternalEvent() + 0xad)
0xf7cb18ef: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa8ef
0x42020650: /usr/lib/libglib-2.0.so.0 + 0x25650
0x4201e3ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0x420213f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0x420218d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0xf7cb1515: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa515
0xf7c7bf41: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x48f41
(X11SalInstance::Yield(unsigned char) + 0x29)
0xbf0850: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88850
(Application::Yield() + 0x50)
0xbf088e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8888e
(Application::Execute() + 0x26)
0x80667c7: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x3c7c7
(desktop::Desktop::Main() + 0x14a3)
0xbf5c73: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dc73 (SVMain()
+ 0x45)
0x80618cb: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x378cb (sal_main +
0x47)
0x496ccde6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8061801: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x37801
(Window::RequestHelp(HelpEvent const&) + 0x31)

Comment 1 Alan Cox 2005-07-18 23:30:35 UTC
Caused by some kind of upgrade/libs problem not oowriter - closing 



Note You need to log in before you can comment on or make changes to this bug.