Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163551 - build of kernel module fails under latest errata
Summary: build of kernel module fails under latest errata
Keywords:
Status: CLOSED DUPLICATE of bug 163406
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 19:52 UTC by greg hosler
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 20:12:19 UTC


Attachments (Terms of Use)

Description greg hosler 2005-07-18 19:52:51 UTC
Description of problem: building standalone kernel modules outside of the kernel
source tree no longer works under the latest kernel errata   

Version-Release number of selected component (if applicable):

      kernel-2.6.12-1.1372_FC3

How reproducible: always (100%)


Steps to Reproduce:
I have a custom kernel module, which I have successfully build on earlier
kernels by doing a

        export KERNEL_VERSION="the kernel version"
        make

The makefile itself has pretty standard stuff:


        KDIR  := /lib/modules/$(KERNEL_VERSION)/build
        PWD   := $(shell pwd)

followed by target definitions.

In all earlier installed kernels, /lib/modules/$(KERNEL_VERSION)/build was a
directory.

in the latest errata, /lib/modules/2.6.12-1.1372_FC3/build is a soft link to

        ../../../usr/src/kernels/2.6.12-1.1372_FC3-i686

My question is:

        is this a bug ? or is this the way of future kernel module builds ?

and

        given this soft link, do we now have to d/l the rource, and
        install it to /usr/src/kernels/2.6.12-1.1372_FC3-i686 ?

I'm guessing that I would need to do a rpmbuild -bp first.


Actual results:

build fails

Expected results:

a built kernel module.


Additional info:

Comment 1 Warren Togami 2005-07-18 20:12:19 UTC
See this other bug for details.  The simple solution is to install the
"kernel-devel" package.


*** This bug has been marked as a duplicate of 163406 ***


Note You need to log in before you can comment on or make changes to this bug.