Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163546 - fc4 installers kernel panic using boot.iso/disc1/dvd VFS: Cannot open root device "<NULL>" or unknown-block(3,2)
Summary: fc4 installers kernel panic using boot.iso/disc1/dvd VFS: Cannot open root de...
Keywords:
Status: CLOSED DUPLICATE of bug 159026
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL: http://twin.uoregon.edu/~joelja/06172...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 19:33 UTC by joel jaeggli
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 20:10:36 UTC


Attachments (Terms of Use)

Description joel jaeggli 2005-07-18 19:33:28 UTC
Description of problem:
On tyan 2882 dual opteron the fedora core 4 installer panics early in the boot
process. we have motherboards with bios version 2882 204 and 303 (latest) 2GB of
f ram dual 244 or dual 252 cpu's. two run fc3 currently without problems, 2
we're trying to install fc4 on. bios is set with failsafe defaults.


Version-Release number of selected component (if applicable):
Linux version 2.6.11-1.1369_FC4 (bhcompile@dolly.build.redhat.com) (gcc version
4.0.0 20050525 (Red Hat 4.0.0-9)) #1 Thu Jun 2 22:56:33 EDT 2005

How reproducible:



Steps to Reproduce:
1.insert cd 
2.boot 
3.panic
  
Actual results:
ÿBootdata ok (command line is initrd=initrd.img ramdisk_size=9216
BOOT_IMAGE=vmlinuz text "console=ttyS0,9600 console=tty0")
Linux version 2.6.11-1.1369_FC4 (bhcompile@dolly.build.redhat.com) (gcc version
4.0.0 20050525 (Red Hat 4.0.0-9)) #1 Thu Jun 2 22:56:33 EDT 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
 BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000007fff0000 (usable)
 BIOS-e820: 000000007fff0000 - 000000007ffff000 (ACPI data)
 BIOS-e820: 000000007ffff000 - 0000000080000000 (ACPI NVS)
 BIOS-e820: 00000000ff780000 - 0000000100000000 (reserved)
initrd extends beyond end of memory (0xeffff91f > 0x7fff0000)
disabling initrd
ACPI: PM-Timer IO Port: 0x1008
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Processor #0 15:5 APIC version 16
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
Processor #1 15:5 APIC version 16
WARNING: NR_CPUS limit of 1 reached. Processor ignored.
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x82] disabled)
ACPI: LAPIC (acpi_id[0x04] lapic_id[0x83] disabled)
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: IOAPIC (id[0x03] address[0xfebff000] gsi_base[24])
IOAPIC[1]: apic_id 3, version 17, address 0xfebff000, GSI 24-27
ACPI: IOAPIC (id[0x04] address[0xfebfe000] gsi_base[28])
IOAPIC[2]: apic_id 4, version 17, address 0xfebfe000, GSI 28-31
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
Setting APIC routing to flat
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 80000000 (gap: 80000000:7f780000)
Checking aperture...
CPU 0: aperture @ f5c6000000 size 32 MB
Aperture from northbridge cpu 0 too small (32 MB)
No AGP bridge found
Built 1 zonelists
Kernel command line: initrd=initrd.img ramdisk_size=9216 BOOT_IMAGE=vmlinuz text
"console=ttyS0,9600 console=tty0"
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 131072 bytes)
time.c: Using 3.579545 MHz PM timer.
time.c: Detected 1992.047 MHz processor.
time.c: Using PIT/TSC based timekeeping.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
Memory: 2056312k/2097088k available (2833k kernel code, 39936k reserved, 1269k
data, 196k init)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
CPU: AMD Opteron(tm) Processor 246 stepping 0a
Using local APIC timer interrupts.
Detected 12.450 MHz APIC timer.
testing NMI watchdog ... OK.
softlockup thread 0 started up.
NET: Registered protocol family 16
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050309
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 15 devices
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI-DMA: Disabling IOMMU.
pnp: 00:0a: ioport range 0x680-0x6ff has been reserved
pnp: 00:0a: ioport range 0x295-0x296 has been reserved
pnp: 00:0a: ioport range 0x778-0x77f has been reserved
pnp: 00:0a: ioport range 0xb78-0xb7f has been reserved
pnp: 00:0a: ioport range 0xf78-0xf7f has been reserved
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
audit: initializing netlink socket (disabled)
audit(1009849103.124:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key E7026A3FC5566DE5
  - key was been created 107918164 seconds in future
- User ID: Red Hat, Inc. (Kernel Module GPG key)
PCI: MSI quirk detected. pci_msi_quirk set.
PCI: MSI quirk detected. pci_msi_quirk set.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: Processor [CPU1] (supports 8 throttling states)
Real Time Clock Driver v1.12
hpet_acpi_add: no address or irqs in _CRS
Linux agpgart interface v0.101 (c) Dave Jones
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled
ÿttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 9216K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD8111: IDE controller at PCI slot 0000:00:07.1
AMD8111: chipset revision 3
AMD8111: not 100% native mode: will probe irqs later
AMD8111: 0000:00:07.1 (rev 03) UDMA133 controller
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
hda: QSI CD-ROM SCR-242, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.01:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 112Kbytes
TCP established hash table entries: 524288 (order: 10, 4194304 bytes)
TCP bind hash table entries: 65536 (order: 9, 3670016 bytes)
TCP: Hash tables configured (established 524288 bind 65536)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.40.2)
powernow-k8:    0 : fid 0xc (2000 MHz), vid 0x2 (1500 mV)
powernow-k8:    1 : fid 0xa (1800 MHz), vid 0x6 (1400 mV)
powernow-k8:    2 : fid 0x2 (1000 MHz), vid 0xe (1200 mV)
cpu_init done, current fid 0xc, vid 0x2
ACPI wakeup devices: 
PCI1 USB0 USB1 PS2K PS2M UAR1 UAR2 GOLA GLAN GOLB SMBC AC97 MODM PWRB 
ACPI: (supports S0 S1 S5)
input: AT Translated Set 2 keyboard on isa0060/serio0
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
VFS: Cannot open root device "<NULL>" or unknown-block(3,2)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

Call Trace:<ffffffff8013a4a5>{panic+133} <ffffffff801cba74>{sys_mount+196}
       <ffffffff801f6ef9>{__bdevname+41} <ffffffff80582c00>{mount_block_root+496}
       <ffffffff80582d85>{prepare_namespace+213} <ffffffff8010c186>{init+326}
       <ffffffff8010fc33>{child_rip+8} <ffffffff8010c040>{init+0}
       <ffffffff8010fc2b>{child_rip+0} 
 <3>BUG: soft lockup detected on CPU#0!

Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.11-1.1369_FC4
RIP: 0010:[<ffffffff8024778a>] <ffffffff8024778a>{__delay+10}
RSP: 0000:ffff81007ffa1de0  EFLAGS: 00000202
RAX: 00000000001a202c RBX: 00000000000023ff RCX: 00000000048ef283
RDX: 000000000000004f RSI: 0000000000000000 RDI: 00000000001ddc88
RBP: 0000000000008001 R08: 0000000000000000 R09: 0000000000002609
R10: 0000000000000034 R11: 0000000000000000 R12: ffff81000326e000
R13: 0000000000008001 R14: 0000000000000000 R15: ffffffff803d794f
FS:  0000000000000000(0000) GS:ffffffff80576c00(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000000101000 CR4: 00000000000006e0

Call Trace:<ffffffff8013a635>{panic+533} <ffffffff801cba74>{sys_mount+196}
       <ffffffff801f6ef9>{__bdevname+41} <ffffffff80582c00>{mount_block_root+496}
       <ffffffff80582d85>{prepare_namespace+213} <ffffffff8010c186>{init+326}
       <ffffffff8010fc33>{child_rip+8} <ffffffff8010c040>{init+0}
       <ffffffff8010fc2b>{child_rip+0} 

Call Trace: <IRQ> <ffffffff8017012d>{softlockup_tick+285}
<ffffffff80113fc1>{timer_interrupt+913}
       <ffffffff801703ec>{handle_IRQ_event+44} <ffffffff801705fd>{__do_IRQ+477}
       <ffffffff8013c54e>{profile_tick+78} <ffffffff801120b8>{do_IRQ+72}
       <ffffffff8010f6c3>{ret_from_intr+0}  <EOI> <ffffffff8024778a>{__delay+10}
       <ffffffff8013a635>{panic+533} <ffffffff801cba74>{sys_mount+196}
       <ffffffff801f6ef9>{__bdevname+41} <ffffffff80582c00>{mount_block_root+496}
       <ffffffff80582d85>{prepare_namespace+213} <ffffffff8010c186>{init+326}
       <ffffffff8010fc33>{child_rip+8} <ffffffff8010c040>{init+0}
       <ffffffff8010fc2b>{child_rip+0} 


Expected results:

expect it to boot.

Additional info:

booting with acpi=off or setting the bios to non-acpi-aware os does not change
the situation.

Comment 1 Warren Togami 2005-07-18 20:10:36 UTC

*** This bug has been marked as a duplicate of 159026 ***

Comment 2 Warren Togami 2005-07-18 20:12:45 UTC
http://forums.fedoraforum.org/showthread.php?p=297874
Read this for workaround details.


Note You need to log in before you can comment on or make changes to this bug.