Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163545 - kernel crashed Assertion failure in __journal_unfile_buffer
Summary: kernel crashed Assertion failure in __journal_unfile_buffer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Stephen Tweedie
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 19:12 UTC by Genghis Rios
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-22 22:21:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Genghis Rios 2005-07-18 19:12:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:

The system crashed, after reboot all is ok, I have a IBM xSeries 345 with 6 hard disk SCSI in hardware RAID 5EE configuration and the ServeRAID-6M Ultra320 controller. The /var/log/messages shows:

Jul 18 12:37:37 xxxxx kernel: Assertion failure in __journal_unfile_buffer() at fs/jbd/transaction.c:1518: "spin_is_locked(&transaction->t_journal>j_list_lock)"



Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.EL

How reproducible:
Didn't try


Additional info:

Comment 1 Stephen Tweedie 2005-07-22 22:21:27 UTC
This looks like a bug which was fixed already in the U1 kernel.  Without a full
backtrace from the oops it's impossible to be more certain.  Please upgrade to
kernel-2.6.9-11.EL.


Note You need to log in before you can comment on or make changes to this bug.