Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163507 - Can't find mod_jk
Summary: Can't find mod_jk
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
: 163508 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 13:33 UTC by Robin Stephenson
Modified: 2008-04-09 18:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-12 10:56:54 UTC


Attachments (Terms of Use)

Description Robin Stephenson 2005-07-18 13:33:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Description of problem:
I've installed Apache 2 via up2date -- httpd-2.0.52-12.ent

I've installed JBoss.

Now I'm looking for mod_jk to hook the two together, but I can't find it.  I've been guessing RPM names; is there a more effective way of doing this (in the same manner as Debian's "apt-cache search"?).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Apache 2 via up2date -- httpd-2.0.52-12.ent
2. Install JBoss
3. look for mod_jk in /usr/lib/httpd/modules
4. randomly type things into up2date to try to find mod_jk
5. Search Google for information; fail
6. Search RedHat knowledgebase for information, fail
7. Redister for JBoss web site
8. Search JBoss web site for information, fail
  

Actual Results:  No mod_jk

Expected Results:  up2date mod_jk should have installed mod_jk

Additional info:

Is there a liaison between RedHts & the JBoss developers?  It seems that there could be more communication; I also noticed that JBoss's "redhat init script" is pretty broken...

Comment 1 Joe Orton 2005-07-18 13:36:05 UTC
*** Bug 163508 has been marked as a duplicate of this bug. ***

Comment 2 Robin Stephenson 2005-07-18 13:54:22 UTC
Found a lead in the JBoss docs: it looks like not only is mod_jk2 deprecated,
but now mod_jk is also deprecated.  However, the replacement, mod_proxy_ajp is
not going to be ready until Apache 2.1.

See http://wiki.jboss.org/wiki/Wiki.jsp?page=UsingMod_jkWithJBoss

So I'm still left with the question: what is RedHat's way of hooking Apache 2 up
to JBoss/Tomcat?

Should I just go with a binary from here:
http://www.apache.org/dist/jakarta/tomcat-connectors/jk/binaries/linux/jk-1.2.10/

I'm uncomfortable; I'd rather have an official RedHat package that is supported...

Sorry about the dupe earlier by the way.

Comment 5 Suzanne Hillman 2005-08-24 17:14:17 UTC
This looks like something for which you would be best off filing a support
request. In order to file a RHEL feature request, please either contact Red
Hat's Technical Support line at 888-GO-REDHAT or file a web ticket at
http://www.redhat.com/apps/support/.  Bugzilla is not an official support
channel, has no response guarantees, and may not route your request to the
correct area to assist you.  Using the official support channels above will
guarantee that your issue is handled appropriately and routed to the individual
or group which can best assist you with this issue and will also allow Red Hat
to track the issue, ensuring that any applicable feature addition is included in
all releases and is not dropped from a future update or major release.


Note You need to log in before you can comment on or make changes to this bug.