Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163501 - Machine freezes when hot-swappable CD-ROM drive is yanked out.
Summary: Machine freezes when hot-swappable CD-ROM drive is yanked out.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 12:33 UTC by Gopikrishnan Sidhardhan
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-26 13:54:37 UTC


Attachments (Terms of Use)
sysrq-t output (deleted)
2005-07-18 12:33 UTC, Gopikrishnan Sidhardhan
no flags Details
dmesg output (deleted)
2005-07-18 12:36 UTC, Gopikrishnan Sidhardhan
no flags Details

Description Gopikrishnan Sidhardhan 2005-07-18 12:33:19 UTC
Description of problem:
The machine freezes when I yank out the hot-swappable CD drive on my laptop, in
multi-user mode.  In single-user mode, it is in a usable state.


Version-Release number of selected component (if applicable):
Occurs with every kernel I tried since FC3.

How reproducible:
Every time.

Steps to Reproduce:
1.  Install Fedora Core 4 on a Dell D800
2.  Yank out the hot-swappable CD drive.
3.
  
Actual results:
The machine freezes.  The following messages are printed continously on the console:
Jul 18 17:08:27 polecat kernel: hdc: DMA disabled
Jul 18 17:08:27 polecat kernel: hdc: ATAPI reset complete
Jul 18 17:08:27 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:27 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:27 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:27 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:27 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:27 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:27 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:27 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: ATAPI reset complete
Jul 18 17:08:28 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:28 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:28 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:28 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:28 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: status error: status=0x00 { }
Jul 18 17:08:28 polecat kernel: ide: failed opcode was: unknown
Jul 18 17:08:28 polecat kernel: hdc: ATAPI reset complete


Expected results:
The machine is in a usable state.

Additional info:
I did a SysRq-t, and got the contents of the attached file in the log.  If I
don't do this, there are absolutely no messages in the log (the messages you see
in 'Actual Results' are printed only on the console and are *not* in the logfile
if I don't do a SysRq-t.

Comment 1 Gopikrishnan Sidhardhan 2005-07-18 12:33:19 UTC
Created attachment 116864 [details]
sysrq-t output

Comment 2 Gopikrishnan Sidhardhan 2005-07-18 12:36:00 UTC
Created attachment 116865 [details]
dmesg output

dmesg output

Comment 3 Alan Cox 2005-08-26 13:54:37 UTC
Linux 2.6 IDE does not support drive hotswap. The 2.6 maintainer seems to have
no plan to ever implement it and in fact has removed the framework of code
designed for adding it.



Note You need to log in before you can comment on or make changes to this bug.