Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163489 - missing buildrequires mozilla-nspr / nspr-devel
Summary: missing buildrequires mozilla-nspr / nspr-devel
Keywords:
Status: CLOSED DUPLICATE of bug 163344
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 10:16 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 10:25:09 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2005-07-18 10:16:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
rebuild of OO in a minimal chroot (mock) fails due to missing buildrequires:
checking which mozilla to use... external
checking whether to use Mozilla or Firefox... Mozilla
checking for mozilla-xpcom ... Package mozilla-nspr was not found in the pkg-config search path. Perhaps you should add the directory containing `mozilla-nspr.pc' to the PKG_CONFIG_PATH environment variable Package 'mozilla-nspr', required by 'XPCOM', not found
configure: error: Library requirements (mozilla-xpcom ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.19434 (%build)

since mozilla-nspr seems to be gone, OO should buildrequire nspr-devel, but
that provides only nspr.pc instead of mozilla-nspr.pc

Version-Release number of selected component (if applicable):
openoffice.org-1.9.117-1.2.0.fc5

How reproducible:
Always

Steps to Reproduce:
1.install mock
2.run 'mock -r fedora-development-i386-core.cfg \
openoffice.org-1.9.117-1.2.0.fc5.src.rpm'
3.check output
  

Additional info:

Comment 1 Caolan McNamara 2005-07-18 10:25:09 UTC
OOo doesn't look for mozilla-nspr, it's one of the moz things which was pointing
to the stale mozilla-nspr itself. Try moilla-xpcom --cflags in the minimal
build-root.

*** This bug has been marked as a duplicate of 163344 ***


Note You need to log in before you can comment on or make changes to this bug.