Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163480 - Installer crashes when trying to show the partition table
Summary: Installer crashes when trying to show the partition table
Keywords:
Status: CLOSED DUPLICATE of bug 161877
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 06:32 UTC by Gusto
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 19:23:46 UTC


Attachments (Terms of Use)

Description Gusto 2005-07-18 06:32:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b3) Gecko/20050714 Camino/0.9a2

Description of problem:
Traceback (most resent call last):
 File "/usr/lib/anaconda/gui.py", line873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/partitioning.py", line 54, in partitionObjectsInitialize
  partitions.setFromDisk(diskset)
 File "/usr/lib/anaconda/partitions.py", line 108, in setFromDisk
  ptype = partedUtils.get_partition_file_system_type(part)
 File "/usr/lib/anaconda/partedUtils.py", line 140, in get_partition_file_system_type
  elif (part.get_flag(parted.PARTITION_BOOT) == 1 and
AttributionError. 'NoneType' object has no attribute 'name'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Booted from cd 
2. Selected desktop during installation 
3. Either click on partition automaticly or using diskdruid
  

Actual Results:  Exception Occurred 

Additional info:

Comment 1 Jeremy Katz 2005-07-18 19:23:46 UTC

*** This bug has been marked as a duplicate of 161877 ***


Note You need to log in before you can comment on or make changes to this bug.