Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163477 - IndexError: list index out of range
Summary: IndexError: list index out of range
Keywords:
Status: CLOSED DUPLICATE of bug 157666
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 01:28 UTC by Ed Solis
Modified: 2014-01-21 22:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-27 20:00:25 UTC


Attachments (Terms of Use)

Description Ed Solis 2005-07-18 01:28:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I run yum update, it sometimes fail with an IndexError: list index out of range. I think it errors when trying to locate a mirror server. It doesn't happen every time though.

This is on a newly installed FC4 system. I'm also behind a proxy server. The proxy server needs authentication. 

Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Sometimes

Steps to Reproduce:
I executed the following command as root:

1. export http_proxy=http://username:password@proxy.example.com:3128/ (not actual user/password/proxy names)
2. yum update
3.
  

Actual Results:  Sometimes yum runs successfully but most of the time it generates a traceback. The error is always an IndexError: list index out of range. 

Expected Results:  yum should run successfully without generating a traceback.

Additional info:

Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 72, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 419, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 877, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 78, in doRepoSetup
    self.doSackSetup(thisrepo=thisrepo)
  File "__init__.py", line 241, in doSackSetup
  File "repos.py", line 281, in populateSack
  File "repos.py", line 726, in getPrimaryXML
  File "repos.py", line 713, in _retrieveMD
  File "repos.py", line 605, in get
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 392, in _mirror_try
    mirrorchoice = self._get_mirror(gr)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 290, in _get_mirror
    return gr.mirrors[gr._next]
IndexError: list index out of range
[root@tungsten tmp]# rpm -q yum
yum-2.3.2-7
[root@tungsten tmp]# rpm -q sqlite
sqlite-3.1.2-3
[root@tungsten tmp]# rpm -q python
python-2.4.1-2
[root@tungsten tmp]# rpm -q python-sqlite
python-sqlite-1.1.6-1
[root@tungsten tmp]# uname -a
Linux tungsten.hq.ntsp.nec.co.jp 2.6.12-1.1390_FC4 #1 Tue Jul 5 19:58:55 EDT 2005 i686 i686 i386 GNU/Linux

Comment 1 Takao Yoshihara 2005-08-16 07:40:41 UTC
 When I run yum update, I have encountered the same phenomenon above.
I re-install yum package, but in vain.
 In adition, my versions of yum and python packages are the same above. In 
spite I don't use a proxy server, I encountered the same phenomenon above.
 Please tell me how to solve this problem.

Comment 2 Rahul Sundaram 2005-08-27 20:00:25 UTC
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 157666 ***

Comment 3 Takao Yoshihara 2005-08-31 06:47:59 UTC
 Dear Rahul

 Thank you for your reply above. According to your direction, I will
mention this phenomenon above in detail.
 I use the dialup-rooter and PHS card in my circumstance. When I run
yum update command, in first its command run smoothly but sooner or later
(about ten minutes later)it faiied to run showing error messages above.
 I guess this phenominon occur when yum update commnand refers to other 
mirrors.
 Will you show me how to solve this problem as soon as possible?
 
                                                           Best regards,
                                                         Takao Yoshihara


Note You need to log in before you can comment on or make changes to this bug.