Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163475 - up2date with incorrect arch specified gives misleading output
Summary: up2date with incorrect arch specified gives misleading output
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 00:20 UTC by Beth Nackashi
Modified: 2008-10-17 19:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 18:58:03 UTC


Attachments (Terms of Use)

Description Beth Nackashi 2005-07-18 00:20:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
If an incorrect arch type is specified in the up2date command (e.g. 'up2date --arch=badarchtype) no error message is output.  Even if the package requested does not exist, up2date will say the package is already updated:

[root@dhcp59-104 tmp]# rpm -q up2date
up2date-4.4.28-3
[root@dhcp59-104 tmp]# up2date --arch=badarchtype ddd

Fetching Obsoletes list for channel: rhel-ia64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated:
ddd
[root@dhcp59-104 tmp]# up2date --arch=x86_64 ddd

Fetching Obsoletes list for channel: rhel-ia64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated:
ddd
[root@dhcp59-104 tmp]# rpm -q ddd
package ddd is not installed

If the correct arch type is specified, the package is successfully updated:

[root@dhcp59-104 tmp]# up2date --arch=ia64 ddd

Fetching Obsoletes list for channel: rhel-ia64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
ddd                                     3.3.9          1                 ia64


Testing package set / solving RPM inter-dependencies...
########################################
ddd-3.3.9-1.ia64.rpm:       ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:ddd                    ########################################### [100%]
[root@dhcp59-104 tmp]# rpm -q ddd
ddd-3.3.9-1

And then if you repeat the same command, an error message is output instead of a message saying the package is already updated:

[root@dhcp59-104 tmp]# up2date --arch=ia64 ddd

Fetching Obsoletes list for channel: rhel-ia64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
ddd                                     3.3.9          1                 ia64


Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package ddd-3.3.9-1 is already installed


Version-Release number of selected component (if applicable):
up2date-4.4.x

How reproducible:
Always

Steps to Reproduce:
1.  See description.
2.  
3.
  

Actual Results:  wrong messages output

Expected Results:  1- with bogus architecture specified, there should have been an error message stating one or more of:  "'badarchtype' is not a valid architecture" and/or "x86_64 is not the correct architecture for this machine" or something else of that ilk.

2- with correct architecture specified and requested package already updated, there shouldn't be a "conflict" message.  up2date should simply say the package is already updated.

Additional info:

Comment 1 RHEL Product and Program Management 2007-10-19 18:58:03 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.