Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163468 - xm create -c xen1 crashes host machine
Summary: xm create -c xen1 crashes host machine
Keywords:
Status: CLOSED DUPLICATE of bug 158367
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 18:51 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 17:48:20 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-07-17 18:51:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.1

Description of problem:
When I run "xm create -c xen1", my computer crashes (the host computer crashes).

Walk through:
# uname -a
Linux localhost.localdomain 2.6.12-1.1398_FC4xen0 #1 SMP Fri Jul 15 01:53:34 EDT 2005 i686 i686 i386 GNU/Linux

[root@localhost ~]# service xend start

[root@localhost ~]# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0      891    0  r----     41.2

[root@localhost ~]# xm balloon 0 384

[root@localhost ~]# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0      384    0  r----     42.3

[root@localhost ~]# cat /etc/xen/xen1
kernel ="/boot/config-2.6.12-1.1398_FC4xenU"
memory = 64
name = "xen1"
nics = 1
disk = ['file:///tmp/xen/1/fedora.img,sda1,w']
root = "/dev/sda1 ro"

[root@localhost ~]# ls -la /tmp/xen/1/fedora.img
-rw-r--r--  1 root root 1074790400 Jul 17 20:17 /tmp/xen/1/fedora.img

Running an strace of xm create shows where the crash occurs:
 send(3, "POST /xend/domain HTTP/1.1\rHost"..., 149, 0) = 149
 send(3, "config=%28vm%28name+xen1%29+%28"..., 403, 0
No further output.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2005-07-18 17:48:20 UTC

*** This bug has been marked as a duplicate of 158367 ***


Note You need to log in before you can comment on or make changes to this bug.