Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 163466 - tpctl/configure-thinkpad require kernel-module-thinkpad
Summary: tpctl/configure-thinkpad require kernel-module-thinkpad
Keywords:
Status: CLOSED DUPLICATE of bug 161036
Alias: None
Product: Fedora
Classification: Fedora
Component: tpctl
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-17 17:47 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-17 17:56:56 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-07-17 17:47:08 UTC
Description of problem:
# yum install tpctl
Error: Missing Dependency: kernel-module-thinkpad >= 3.2 is needed by package tpctl
- same for configure-thinkpad. They require the kernel modules rtcmosram, smapi,
thinkpad (at least). It's unclear to me whether thinkpad_source contains
proprietary stuff, in which case refer me back to Livna, but it's not hard to
build a working .spec for FC4 with the latest thinkpad, 5.8-4. It's in a debian
repository, so at a guess it's free:

ftp://ftp.debian.org/debian/pool/main/t/thinkpad/

My (very hacked and not portable) spec file taken from Dag's compiles ok with
gcc4 and works. Or it could just be supplied as modules in the kernel?

Version-Release number of selected component (if applicable):
thinkpad 5.8.4
tpctl 4.17-2

How reproducible:
Infinitely

Steps to Reproduce:
1. yum install tpctl
2. stare at the screen
3. file a report
  
Actual results:
Error: Missing Dependency: kernel-module-thinkpad

Expected results:
Installs ok.

Additional info:

Comment 1 Ville Skyttä 2005-07-17 17:56:56 UTC
 
 

*** This bug has been marked as a duplicate of 161036 ***


Note You need to log in before you can comment on or make changes to this bug.